Coursepress unit stays incomplete

Hey guys,

Hope you're doing well :slight_smile:

I'm having a major issue concerning completion of units with mandatory and graded elements. Here is the case : A user see the unit, sends mandatory and graded assessment, then i grade it successfully. After that, the unit stays incomplete, and the user cant continue.

Support access is already enabled. Please use the "wpmudev" super admin account to access the subsite (you can change the account password).

To see the issue in live, you can use the "test" account and change the password also to log in.

Thx for your time and hope you will have the time to get it fix quickly as all users are stuck now :slight_frown:

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hello there, Mehdi! I hope you're well today, as well!

    Sadly, it looks like we had a glitch on our end and support access didn't take. Can you try revoking and re-enabling it? Post here when you have and I'll hop right in.

    There was an earlier bug with a similar outcome, just to be sure, are you using the most recent version of CoursePress on your sites? If not, upgrade just to be sure the problem persists.

    Thanks!

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hey, Mehdi!

    I've spent quite a bit of time poking around on your site and a similar setup on my own, and I think the issue is related to the number of times a student may attempt to answer a question. So, for example, if one of your students got a grade of less than 100% from you, they'd be able to retry for a higher grade, until the limit attempts number is hit. Try disabling this and check to see if students are seeing the results they should.

    Thanks!

  • Mehdi
    • Flash Drive

    Hi Michelle,

    Thx for your time ! I disabled the "Limit Attempts" option and thats the same. The element is stuck on (1 attempt remaining). Even if i try and try again to send a file, it stays on (1 attempt remaining).

    You can make some changes and tests with the account "test" on the site.

  • Mehdi
    • Flash Drive

    Hey guys,

    Hope you're fine today :slight_smile:

    Do you have some news about this issue ? All students are stuck in their progress now and everybody is complaining at the same time. Its a little difficult to manage :slight_smile:

    Take care guys !

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hi Mehdi and Joanne!

    I'm still not able to reproduce this issue on my test sites, but since I can reproduce it on yours, we've ruled out a conflict with another plugin on your site, and done other troubleshooting, I've asked to dev to weigh in via a ticket. Thanks so much for your patience, hopefully we can find the connection.

    If you wouldn't mind, would you both consider sending me some access information for your site, so if the developer needs to take a closer look, he can? If this is okay, you can use our secure contact form to send in the following:

    https://premium.wpmudev.org/contact/

    Subject: "Attn: Michelle Shull"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    You can create a new admin account for our team to use, and delete it once the issue is resolved to keep everything secure.

    Thanks again!

  • Mehdi
    • Flash Drive

    Hey guys,

    Hope you're fine today :slight_smile:

    I know that you have a lot of work, but i have to insist on this issue as its affecting the hole site and all my students.

    News infos about the issue : it only affects units with "file upload" element. When a student completes a unit with just a video or even with a mandatory quiz, the unit goes to 100% and the student has access to the next unit.

    Thx for your time guys, and please make this a priority.

  • Joanne
    • Site Builder, Child of Zeus

    This is ridiculous, the plugin is useless if a student can never complete a course! I am dealing with angry students demanding refunds, get this sorted asap please, and by the way we are still using the beta version of the last fix, it hasn't even been made public!!!!!!

  • Jose
    • Bruno Diaz

    Hello @Mehdi and @Joanne,

    I prepared a new beta version that includes a fix for gradable results not being updated correctly.
    You can download it here: https://dl.dropboxusercontent.com/u/21559010/coursepress_1.2.5.9_beta02.zip

    Once you install this version, you should go to
    CouspresPro->Assessment
    and re-save the grades.

    Now, the progress should be updated accordingly for students.

    Please let me know if it works as expected in your sites.

    Thanks again for your patience and cooperation :slight_smile:

    Cheers,
    José

    • Jose
      • Bruno Diaz

      Hi Mehdi,

      Yes, you need to go to every assignment and re-save them (attaching a screenshot to ensure that we are n the same page).

      I realize that this can be annoying if there are too many assignments. How many our we talking about in your case?
      I'll try to think on a way to automatize this.

      Cheers,
      José

  • Mehdi
    • Flash Drive

    Hey Jose,

    Yes this a little annoying but i have some 20 or 30 assignments so i can handle it for now :slight_smile: Thx

    The bug seems to be fixed. I will keep you updated if the students find something else.

    Take care !

  • Joanne
    • Site Builder, Child of Zeus

    After installing this update the issue is still there!!! I have done as instructed and re-saved the assessment grade but the issue is still there, progress shows only 13 of 18 mandatory answers have been completed which is WRONG!!!!!!!!!!!!!!!!!

  • Joanne
    • Site Builder, Child of Zeus

    The issue is the file downloads, its including these as mandatory elements but not recognising when a student has downloaded them!!!! Therefore they are never able to complete a unit, you guys have had plenty of time to get this sorted, once again I am faced with angry students demanding refunds and I have wasted valuable time trying the various fixes you have recommended, sort it out please, this is affecting my business and reputation!

  • Joanne
    • Site Builder, Child of Zeus

    After some more digging its definitely the file download that is the issue, I have managed to get the process to update to 0 out of 5 mandatory elements completed but i have set all the answer field and single multiple choice questions to not mandatory, the only thing left is 5 file downloads!!!!!

  • Joanne
    • Site Builder, Child of Zeus

    When I remove the file download and replace with normal hyperlink it still shows Introduction 0 of 5 mandatory elements completed even though there are no mandatory elements I have set and I have viewed every page, the issue is unresolved and I am at my whits end now

  • Joanne
    • Site Builder, Child of Zeus

    Why is it other members who have posted questions today have had replies and I haven't? I would appreciate a response as this is urgent, you gave us a beta version that has caused problems and isn't a workable fix!

  • Jose
    • Bruno Diaz

    Hello Joanne,

    Why is it other members who have posted questions today have had replies and I haven't? I

    This is because not all the staff is subscribed to all the threads.
    In this case, I'm following up on this thread. The delay is mainly due to my different time-zone, plus that we have a work queue ordered from older to newer.

    That said, thanks for your feedback.
    I worked based on the feedback from Mehdi, who was having issues with the completion for File Upload modules.
    I'll try to reproduce the problem that you mention with File Download modules. It will be great if you can grant me access to your site so that I can debug directly there.

    If that's ok for you, please send me the following information via contact form :

    - In the subject field add "Attn: Jose”
    - Link back to this thread
    - Include WP admin/network access
    - Include FTP host and credentials.

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    Thanks in advance,
    José

  • Joanne
    • Site Builder, Child of Zeus

    I have granted access, I am not even sure its to do with file download now as I removed them and made them just a hyperlink and that didn't have any affect. I have tried all combinations, graded questions ungraded questions, mandatory non mandatory, no matter what I try it still says there are 0 of 5 mandatory elements! I have lots of students already started and its affecting my business and I'm not the only unhappy member! My students don't know where they are up to and its costing me time and money every day this isn't fixed.

    • Jose
      • Bruno Diaz

      Hi Joanne,

      I understand how frustrating can this be.
      Granting access wouldn't be enough since I need to check things in your DB and add some debug traces in the code. It would really help to speed things up if you can send me the information requested above.

      Thanks,
      José

  • Joanne
    • Site Builder, Child of Zeus

    I have set up a guest learner for you José, i have emailed the login to you

    I have enrolled you on the holistic crystal which I changed the questions in unit 1 to non mandatory to see if this made a difference but it didn't. This issue affects every course and every student!

    I have lots of students that have completed at least 2 or more units and a few who have nearly completed a course and have completed a lot of questions , AL report progress tracking issues and all experience not being able to move onto next unit regardless of how I set up the course, mandatory non mandatory, graded ungraded this is unworkable for courses as I need the flexibility to use both. I DO NOT want to lose any students work and I would like this sorting asap please

  • Joanne
    • Site Builder, Child of Zeus

    I have sent an email this morning, still having issues despite the work you carried out! Now I have more issues, when I comment on a students answer it puts the same comment in every comment box even questions they have not submitted answers to! Also checkout doesn't work so nobody can purchase anything so more refunds I am paying out to angry students and I can bring any income in! I would like compensation and an actual fix to all these issues please!

  • Joanne
    • Site Builder, Child of Zeus

    This is ridiculous and not acceptable, nearly 5 days waiting for a response, no reply to any of my emails to Jose either. I am extremely annoyed and not willing to be ignored any longer. Can someone in authority reply to my request immediately please!?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.