how adjusting "A" records in godaddy

please when a user use a domain he already have from godaddy
is entering dedicated ip for "A" record sufficient for domain mapping to work ?

  • Tyler Postle
    • CGO

    Hey Ahmed,

    Yes that should work providing that your dedicated IP is pointing to your WordPress installation. When you enter your IP Address into the address bar does it take you to your installation or a parked page somewhere?

    If you post your dedicated IP here then I can check that for you as well :slight_smile:

    Look forward to hearing back!

    Cheers,
    Tyler

    • Sean
      • WPMU DEV Initiate

      If I have read this correctly, your client owns (for the conversation) example.com, and wants to point it toward your WordPress server so that he can access his site at example.com/wordpress

      If that's correct, you'll need to have your client point his "A" record with GoDaddy to the IP Address of your WordPress server, map his domain name to example.com/wordpress, then after GoDaddy updates his ZONE file worldwide, he should be able to access his site at example.com/wordpress

      Somebody, if I am missing something, please reply.

  • Ahmed
    • WPMU DEV Initiate

    map his domain name to example.com/wordpress

    how is this done in godaddy dns manager
    i can only change the A record to the ip
    how is that mapping done
    Note: i know that this can be done by dns manager at cpanel but i need the way it is made totally from domain dns manager

  • Tyler Postle
    • CGO

    Hey Ahmed,

    Hope your weekend is going well so far!

    I checked your IP and it looks like it is pointing at your installation so that should be fine.

    After you enter your IP into your A record for the domain you are trying to map, does it still say it's invalid when you actually try to map it within the plugin? You might want to go to:

    Network Admin > Settings > Domain Mapping.

    and turn off the "verify DNS" option. Then see if it maps properly, sometimes the invalid dns check might be erroneous.

    If it still doesn't work after that then ask your host or the host where the domain is, to ensure that it is being pointed to the correct spot.

    Also, if the domain you're trying to map uses the same DNS servers your site is on then you will have to use either the add-on or parked mapping method as shown near the end of the domain mapping usage guide: https://premium.wpmudev.org/project/domain-mapping/#usage

    Hope this helps Ahmed!

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.