How can I change the global store page under scribe

Hi,

How can I change the global store page under scribe to display a smaller image. Now it is so huge and distorted. Or maybe I could display the items in grid and not in a list?

triple-grace.com/global-store

Michael

  • Denitsa

    Hello Michael,
    I hope you are having a fantastic day!

    Strangely, the settings under Store Settings -> Presentation for the thumbnail sizes are not having effect on your page. You can try inserting the following CSS and see if it works for you

    .mp_products .mp_product_image_list {
    width: 100px;
    }

    This can be inserted in your Global Theme CSS via Upfront or using a plugin like this one.

    You can toggle grid/list settings under Store Settings -> Presentation.

    Also, you site seems to load extremely slow for me, what are your server's specs? Are you on a shared hosting?

    All the best,
    Denitsa

  • Sajid

    Hello Michael,
    Hope you are doing good today

    Thanks for enabling support staff access. The reason it was not displaying products in grid on global cart page was the wrong shortcode.

    The correct shortcode to display the products in grid is below:
    [mp_list_global_products paginate="1" list_view="0"]

    Also, I noticed that you set thumbnails for product images in grid. That size was very small and was not suitable for grid. I changed the size thumbnail to medium from Main Site Dashboard -> Store Settings -> Presentation -> Product List / Grid Settings -> Image Size.

    I also changed the number of items to be display in a row from 2 to 4 from Main Site Dashboard -> Store Settings -> Presentation -> Product List / Grid Settings -> Product Layout -> Display as Grid. And selected four products per row from Main Site Dashboard -> Store Settings -> Presentation -> Product List / Grid Settings -> Product Layout -> How many products per row?.

    Yes, I noticed the slow site load. But it is not only on MarketPress or Upfront pages. It also caused this slow loading issue in WordPress admin pages too.

    That appears to be issue of your server. Even though you have very good server specs but maximum memory limits and execution times are set to low. The maximum memory is 512 and execution time is 30 seconds for PHP. That further reduced to 256M for WordPress (you might added define('WP_MEMORY_LIMIT', '256M'); in wp-config.php file).

    To further increase the memory and execution time, please follow one of steps mentioned in this blog post:
    https://premium.wpmudev.org/blog/increase-memory-limit/

    Before making the changes, note down the existing memory limit and execution time in WPMU DEV -> Support -> System Info -> PHP, so you could compare those later to make sure the changes are actually take effect.

    If you still need help with site performance/speed then please consider creating a separate support ticket and we would love to help you boost site speed and performance. We will provide you further suggestions and tools that you can use to increase the site speed/performance.

    Take care and have a nice weekend!

    Best Regards,
    Sajid - WPMU DEV Support