How can I change the noindex on the main page when using upfront?

I just notices that all new created websites have the noindex follow on the main page. But I cannot find any way of changing this settings. All the other pages are OK, but the home page is not showing as a page, so a website with just one page shows as having no pages at all.

The websites are not blocked in robots txt file, it's just the home page with noindex.

Thank you

The original question is: https://premium.wpmudev.org/forums/topic/noindex-on-the-main-page-upfront
But I think it's in the wrong forum, the problem could be with SmartCrawl not UpFront

  • Rupok

    Hi Mario,

    Please install and activate SmartCrawl plugin. Then go to "Dashboard > Settings > SmartCrawl" and go to "Step 3: Title & Meta" tab. There, put checkmark on both "nofollow" and "noindex" option under "Main Blog archive Meta Robots" option and save. Please check the attached screenshot for reference.

    This will add the following meta tag in your Upfront homepage:
    <meta name=&quot;robots&quot; content=&quot;noindex,nofollow&quot;/>

    I believe this will serve your purpose. Please let us know if you have any confusion. We will be glad to help.

    I think it's in the wrong forum

    As both the threads are regarding the same issue, I'm closing the other one. It's better to have one ticket for one issue, it helps both you and us to track down solutions.

    Have a nice day. Cheers!
    Rupok

  • Mario

    Good to know if you're using Upfront and SmartCrawl:
    Having No Index or No Follow to Main Blog archive Meta Robots - actually means having noindex and nofollow to your home page.

    I always have a noindex to archives, author pages, etc, in order to keep indexed only the relevant pages - like the home or blog posts, instead of the blog archive page.
    But this would "kill" a website using upfront!

    Thank you.
    Case closed.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.