how can i down grade to a earlier version of wordpress?

how can i down grade to a earlier version of wordpress?
im currently have wordpress WordPress 4.1 multisite and i want to use buddypress but buddypress is not tested with my version and is not working properly.it says it is only Compatible up to: 4.0.1
my website is bgvsbb.com
i keep getting these error messages

Not Found

The requested URL /activity/ was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.2.26 (Unix) mod_ssl/2.2.26 OpenSSL/1.0.1e-fips DAV/2 mod_bwlimited/1.4 Server at bgvsbb.com Port 80

Not Found

The requested URL /members/ was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.2.26 (Unix) mod_ssl/2.2.26 OpenSSL/1.0.1e-fips DAV/2 mod_bwlimited/1.4 Server at bgvsbb.com Port 80

Not Found

The requested URL /groups/ was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.2.26 (Unix) mod_ssl/2.2.26 OpenSSL/1.0.1e-fips DAV/2 mod_bwlimited/1.4 Server at bgvsbb.com Port 80

Not Found

The requested URL /blogs/ was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.2.26 (Unix) mod_ssl/2.2.26 OpenSSL/1.0.1e-fips DAV/2 mod_bwlimited/1.4 Server at bgvsbb.com Port 80

how can i fix this problem?