How can I figure out how to fix this error with snapshot?

I keep getting this error and I don't know what it is for. I have increased the memory, etc. I need to be able to have a full snapshot because I'm going to restore it under a different domain name.

  • Paul

    @Jacob,

    I don't think the issue is memory related. Looks like you have enough memory allocated. Generally this error is caused by some untrappable error which occurred and snapshot didn't received the proper AJAX reply.

    Try going to the server via FTP. Look into the folder /wp-content/uploads/snapshots/_logs/ Look for the newest file with the .log extension. See image. This is probably the one from the aborted session. See if it provides any details on the issue.

    Also, go to Snapshots > Settings. Go to the bottom of the page. You will see the section 'Error Reporting'. Make sure all the checkboxes are set.

    Finally, try running another snapshot but excluding the table(s) where the abort occurred.

    Let us know if you make better progress.

  • Paul

    Thanks for the help! It doesn't seem to show any reasons why it aborted.

    Hmm. I really didn;t think it would but I always like the check the logs just in case.

    If I exclude the table and it finishes, will there be a proper restore when I use the snapshot though?

    Excluding the table(s) was not to be the final solution but more a way to identify the issue causing the abort. If you for example excluded the one or two tables and the next snapshot finished then it is likely there is an issue with the table we investigate in the next step. If however you exclude the table and still having the same issue then nothing list.

    Yes, ultimately we want to get to including all tables. But again per your image those tables shows just at the about are not standard WordPress tables. So I'm not sure about how large they are.

  • Jacob

    @Paul

    Sorry, I was away for the weekend. I am still trying to tackle this issue.

    I did what was suggested and excluded the table the error was happening on. It went to the next table and had an error, so I excluded both. Then the next table had an error. I did this for about three tables, and every time I excluded another table, the very next one was the one that messed up.

    I've attached a screenshot.

    What should my next step be?

  • Paul

    @Jacob,

    Well I'm really not sure what to suggest next because we have not uncovered any specific error. Any chance you can check your server logs to see if something is being reported? Or is anything try turning on WP_DEBUG in your wp-config.php ( http://codex.wordpress.org/Editing_wp-config.php#Debug )

    Also, from your screenshot all the tables do not have familiar WordPress names. So assuming these are just extra tables on your system which is fine. But I'm interested to see if we can maybe first get the WP core tables included only. See if we can get a snapshot to complete somehow.

  • Jacob

    @Paul

    I'm sorry I am going back and forth and getting behind on the replies on here.

    Yes, I did successfully complete a snapshot when ran just the core tables.

    No I have not enabled WP_DEBUG because I'm having a hard time finding the wp-config.php file to edit it, as embarrassing as that is. I'm still not a WordPress pro, and it has a nice way of reminding me of how little php I actually know.

  • Paul

    @Jacob,

    No problem. It might be quicker and less back and forth if you could provide access to your site wp-admin so I can see things directly.

    If you are willing to provide access do not post the details here as this is a public thread. You can use the contact form https://premium.wpmudev.org/contact/ on the dropdown select 'I have a different question'. In the message area reference this thread URL and mention my name. And if possible provide FTP account details so I can get to Snapshot and enable some debug output so we can figure out where things are stopping.

  • faydra_deon

    @Jacob:

    I had a feeling you were going to say GoDaddy.

    I've used Snapshot on Bluehost, MediaTemple, IX Webhosting, Digital Ocean, Hostgator, Dreamhost, Fatcow, 1and1, Network Solutions and GoDaddy.

    I've only ever had issues on Network Solutions and GoDaddy.

    On Network Solutions, it was the client's package.

    On GoDaddy, it was just weird. This is extrememly fresh in my mind, because it was only about five days ago that I went through this.

    You may not want to try this, and you may even think I'm nuts, but I'm going to tell you how I got this to work on GoDaddy.

    First of all, I was restoring from the local server, not Dropbox or Amazon.

    I started the first snapshot restore and it errored out, just like yours did. I checked all the stuff you normally check, and everything was fine.

    I deleted the partial file created by that failed snapshot restore and tried to restore again. It failed, too.

    Before I deleted the second failed snapshot restore, I clicked "Abort" next to the item where the snapshot restore failed and then I went and deleted the failed snapshot restore file that was partially created.

    I started another snapshot restore, which failed also. Before I deleted the third failed snapshot restore, I clicked "Abort" next to the item where the snapshot restore failed and then I went and deleted the failed snapshot restore file that was partially created.

    I started a fourth snapshot restore, which failed also. Before I deleted the fourth failed snapshot restore, I clicked "Abort" next to the item where the snapshot restore failed and then I went and deleted the failed snapshot restore file that was partially created.

    I started a fifth snapshot restore, and the darn thing completed without issue.

    I've only had this experience on GoDaddy, and I had to have that snapshot restore complete, because it was for a site migration for a client who I was soooo ready to be done with. I'd taken the snapshot of the demo site I did, and that demo site was totally gone by the time the client finally contacted me to give me his hosting details, so I had to get that snapshot to restore, or I was going to have to recreate the live site from scratch.

    Then I set up a demo subdomain on the client's GoDaddy hosting to see if I could replicate the failures and the final restore.

    As a designer/developer, I'm always trying to see how different hosts handle stuff, which is why I've used Snapshot on so many different hosts.

    It did the exact, same thing, but with the replication test I clicked "Abort" next to where the snapshot restore failed on the first failure. It only took me three failures before the snapshot would restore.

    Like I said, you may think I'm crazy, and you may be skeptical to try this, but it's what worked for me and kept me from having to tell the client, with whom I was on bad terms at that point, that I couldn't get his site set back up like the demo he had approved.

    I should also mention that I did all those restore/failure/try again steps back-to-back-to-back. I didn't wait several minutes between each one. When I did the demo subdomain to try to replicate the scenario, I did those one right after the other, too.

    I wouldn't say I "brute forced" it to work like I needed it to. I will just say that I think I hit that little "pocket" where GoDaddy was willing to act right and let the snapshot restore complete.

    Good luck with this. I hope you get it working.

    Faydra...

  • Paul

    @Jacob,

    Ok. Checked some things and tried a few combinations of manual snapshot. Trying all tables and only media worked. But then trying all tables and media and plugin or themes would not.

    I then noticed some things with your server. When the snapshot failed it I then tried to reload the page I was getting connection errors. Basically unable to load the page for a few seconds.

    So then cleared out my testing snapshot instance and started a new on. You can see it on the All Snapshots listing titled 'WPMUDEV Test'. On this testing I setup snapshot to run in non-interactive mode. This means as a scheduled task running on a 5 minutes interval. Things are now working for all file and all tables.

    So the take away on this is I think when running the interactive type which is many multiple AJAX calls from the browser to the server might be causing an issue. It could be something as simple as GoDaddy thinking someone is trying to brute force your site.

  • Paul

    Ad it appears Snapshot is not totally out of the wrong. In the log files for the successful archives I'm seeing some warnings (see below). Working in trying to get those to go away.

    2014-01-22 00:02:32: init
    2014-01-22 00:02:40: Warning: errno:2 stristr() [function.stristr]: Empty delimiter /home/content/32/11062532/html/test/wp-content/plugins/snapshot/snapshot.php on line 6987
    2014-01-22 00:02:40: Warning: errno:2 stristr() [function.stristr]: Empty delimiter /home/content/32/11062532/html/test/wp-content/plugins/snapshot/snapshot.php on line 6987

  • Paul

    @Jacob,

    Sorry I meant to get back to you earlier on my testing. No the 'WPMUDEV Test' snapshot is not slower just running as a non-interactive backup. Please refer to the attached image and read below.

    Basically Snapshot has two ways you can create a snapshot. When you go to the Snapshots > Add New form and select the settings the default is to create the archive at one in interactive mode (Immediate). This is when you see the pretty progress bars. The problem is the multiple AJAX calls used by the pretty screen to drive the backup of each database table and file on your site is getting blocked. Some server see repeated AJAX or just pages load within that close of a time as a potential security issue. So they setup automatic blockers to stop them. GoDaddy does this.

    The second way to create a snapshot archive and the one you really want over time is to creates a scheduled backup. On the form you can see the options on the Backup Interval dropdown. See image. This lets you select one a day, twice a week etc. When running this mode of backup the processing is done all at the server. There are not multiple request over AJAX that might be stopped by your hosting.

    So where to go from here? First you can delete my WPMUDEV Test shapshot item.
    The go edit one of your other snapshot items and select all file and all tables. Select a comfortable backup interval. Then save it. The backup will run when needed.

  • Paul

    @Jacob,

    Well some notes on your comment. Yes in theory if you set the interval to once an hour it will backup once an hour. So in a 24 hour period you would expect 24 archive. But snapshot relies on the WordPress Cron engine (WPCron) to actually start the process. And the WPCron system is not a perfect scheduler in that is needs front-end traffic to keep it working.

    As for the restore you can chose to restore an of the previous backups not just the most recent. So on the All Snapshot listing you hover on the title (first column) row and select the 'restore' option. This takes you to a second listing showing all the archives for the snapshot configuration. You can chose the one to restore. Then on the third page of the restore process you have some options about what to restore.

  • Paul

    @Jacob,

    Will I be able to migrate this snapshot to a different domain and "restore" it there to transfer my site and all its data?

    Correct. For that you will first need to Import the snapshot archive in the new system. You will see the Snapshot > Import option on the site where you are going to run the restore. This import gets the archive into the snapshot configurations. Once imported you then go to Snapshots > All Snapshots and it should show in the listing. From there click the restore to the last page of options. On the last page you will see where snapshot figure out the archive was not created on that server. If will show you information about what the database prefix is changed to the URL it not the same, etc. IF you have any questions let us know.

    • Adam Czajczyk

      Hello kathrynjones,

      Thank you for your valuable feedback on this.

      Please note however that the original thread here is quite old so the code of the plugin and available options has changed a lot. As GoDaddy (and other hosts) are offering different hosting packages/solutions that may not always be the same case too. I hope that makes sense.

      That said, in case you wanted to give it some more troubleshooting, don't hesitate to start a live support session with us and we'll be happy to assist you. Or, if you prefer to stick to the forum, let me know here please and I'll create a separate support thread for you so we wouldn't keep this one (over 3 1/2 years old one) going on.

      Best regards,
      Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.