How can I get new sites added after installing Multi-Domains for MS to load?

Just installed Multi-Domain plug in and set up a second domain and a new test site using the new domain. During setup, all looks OK but when I access "Visit Site" or "Dashboard" the new site will not pull up. All sites set up on the initial primary domain pull up fine including a new one I attached to the original primary domain (investorsguaranty.net) after installing multi-domain.

The new domain I am having problems with is globalfirst.com. The new site is "Global First 120" at http://test120.domain1.com/wp-admin. Comes up with a 404 error. I've tried other domains and other sites on another server build but get the exact same result. The instructions were a little confusing as to what does and does not need to be moved (.i.e. sunrise and wp-config.php) or edited so I'm guessing that may be my issue.

You should have access to take a peek. Thanks in advance!

Curtis

P.s. All plugins, Word Press 4.0 are current as of this message.

  • Tyler Postle

    Hey Curtis,

    Hope you're doing well today!

    Did you just purchase the domain and just setup the DNS? Those can take some time to propagate which could be the issue here. Sometimes it's within 20-30 mins other times it can take hours.

    Do you have a dedicated IP address? If you place it into your address bar and it takes you to your WordPress installation then you have one :slight_smile:

    If you have a dedicated IP but it isn't pointing to your WordPress installation then speak with your host, they will be able to fix that.

    Look forward to hearing back Curtis!

    All the best,
    Tyler

  • Curtis

    Hi Tyler,

    Everything has propagated. I can set up the same domain and point it to another server and it will work fine.

    I'm using dedicated servers with Amazon instances and static IP addresses. I manage my DNS and registrations all all seem to be working. My TTL is low and propagation is taking less than 10 minutes world wide. The problem only occurs after I install Multi Domain to attempt a second domain. I've repeated the problem about four times now on four different servers using different domains. Same result every time. The initial primary domain will work fine but the secondary domain will not.

    Can you check the sunrise.php and the wp-config.php files and make sure they are set up correctly? The plugin instructions are a bit confusing because they tell you to ignore moving files as they are automatic now but later in the instructions tell you to make the changes. Various dialogue boxes on different screens advise differently. It is early in AM here so apologies if I'm just not getting it.

    This URL will get a 404: http://test120.domain1.com/wp-admin
    This URL hit the bitnami front end: http://test120.domain1.com
    Static IP goes straight to the bitnami interface.

    Also, I just set up a third domain and same 404 problem:

    http://test426.domain2.net/wp-admin

    Thanks,
    Curtis

    • Curtis

      I found the solution to the problem in the Bitnami Wordpress Multisite documentation. I just needed to make a simple change in httpd-vhosts.conf and restart. The new domains are working now.

      IMPORTANT: WordPress Multisite is configured to use subdomains by default. If you are going to point any domain to your WordPress application, it is necessary to edit the "/opt/bitnami/apps/wordpress/conf/httpd-vhosts.conf" file to accept any domain. Replace the following option in the file and restart the Apache server:

      ServerAlias *.yourdomain.com

      with

      ServerAlias *

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.