How can I Include originating blog information in to post?

How can I Include originating blog information in to post from the feed?

Thanks

  • Kimberly
    • Champion of Loops

    Hello playhays,

    The only option you will have for importing the number of posts will be to use the Feed Processing options. If you leave this set to posts. it will import as many as it can

    I will attach a picture. :slight_smile:

    Best,

    Kimberly

    If the above action did not result in the resolution or common end to this ticket then please feel free to come back here for comment. Just be sure you mark "Not Resolved" to re-open or we might miss it! :slight_smile: Thanks!

  • playhays
    • Site Builder, Child of Zeus

    Thanks Kimberly for the reply, this is not really what I am trying to do. I will clarify.

    I am using autoblog to pull in feeds/posts, and I have “Enable External Permalinks for Autoblog ” Inactive.

    So the posts are being recreated in my site.

    What I need to know, is how do I have import the original sites information? To show the source?

    Thanks

  • Kimberly
    • Champion of Loops

    Hmm, if the external links are not being created then perhaps you can use the" Link to original source" option in the Autoblog feed creation (also visible upon clicking to edit a feed)

    I'll attach a pic. Would this meet your requirements? Or were you looking for another way of doing this?

  • playhays
    • Site Builder, Child of Zeus

    Thank Kimberly,

    This option works if I am pulling a feed directly from one of my networked sites.

    However I am using post indexer to draw all of the post into the parent site, then pulling them back down into other sites by category. So even though I have text in “Link to original source” there is no link available on the post.

    Any thoughts on this?

    Thanks

  • Cole
    • The Incredible Code Injector

    Hey playhays,

    Great talking with you on live chat. I wanted to post the fix I came up with in here in case someone runs into a similar issue in the future.

    This drop-in plugin can be name anything ending with .php in your wp-content/plugins/ folder. After you upload make sure and activate it or network activate it depending on your setup.

    <?php
    /*
    Plugin Name: Post Indexer Autoblog Fix
    Plugin URI: https://premium.wpmudev.org
    Description: Fixes the source not displaying when imported from autoblog
    Version: 1.0
    Author: Cole (incsub)
    Author URI: https://premium.wpmudev.org
    License: GPLv3

    This program is free software: you can redistribute it and/or modify
    it under the terms of the GNU General Public License as published by
    the Free Software Foundation, either version 3 of the License, or
    (at your option) any later version.

    This program is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
    GNU General Public License for more details.

    You should have received a copy of the GNU General Public License
    along with this program. If not, see <http://www.gnu.org/licenses/>.

    */
    add_filter('the_content', 'autoblog_source_content',5);

    function autoblog_source_content($content) {
    global $post;
    if($orig_source = get_post_meta($post->ID,'original_source',true)) {
    update_post_meta($post->ID,'original_source_link_html','<a href="'.$orig_source.'" rel="nofollow" target="_blank">View This Source</a>');
    }
    return $content;
    }

    There seems to be some issue with Post Indexer and Autoblog. Kim, maybe its worth flagging Barry to take a look at the issue and my temp fix?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.