How can I inhibit Jobs and Experts from Creating Dummy Accounts?

Each time I try to edit the settings for Jobs and Experts to show no dummy accounts in settings I end up with several blank jobs and experts . I have created my own sample expert, and job and I think the extra ones being auto generated look terrible. It is very frustrating to do this over and over again just to get one sample job and one sample expert. Please advise.
Thanks,
Robert Miller

  • Tyler Postle
    • CGO

    Hey Robert,

    Hope you're doing well today!

    Jobs and Experts shouldn't be automatically creating sample jobs or experts. Unless you activate the demo data add-ons and click the button to create it. Are you saying that it keeps creating them even after deleting them?

    If that's the case could you grant support access so we can take a closer look? :slight_smile:

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    I would recommend leaving the jobs/experts demo data add-ons deactivated if you don't already have them set to that, then manually creating a job and expert, which is what it sounds like you are doing now.

    Look forward to hearing back on this!

    All the best,
    Tyler

  • Robert
    • Flash Drive

    So I did grant access last night. I had deleted the initial set of dummy jobs/experts. I created my own sample job and expert. I unchecked the box that said something like"Have Sample Data." I saved...and ended up with dummy data. I've repeated this process several times with the same results. Hope this helps. Checked this morning and all of the settings under "Jobs Data," is reset to default settings.
    I extended access this morning.
    Thanks,
    Robert Miller

  • Ash
    • WordPress Hacker

    Hello @Robert

    I hope you are well today.

    I created my own sample job and expert.

    How did you create this? From Dashboard > Jobs > Settings > Jobs Demo Data? Where did you see "Have Sample Data." option? Sorry if I an missing something.

    There is a checkbox for "Have sample files" that means when sample jobs data will be created, there will be some sample files will be auto created. If you please explain how I can replicate that, I will try in my test site.

    Please let us know.

    Cheers
    Ash

  • Robert
    • Flash Drive

    Hi Ash,
    First in Jobs>Manage Jabs I deleted the Jobs listed and used the "Add Job" at the top to create a job I called "Sample".

    Next I created some job categories from "Job Categories" just to experiment.

    Third, I made some minor changes in Jobs > Job Settings, including setting the Job Records per Page to 1 ( I see it has now again defaulted to 10).

    Fourth, in Jobs >Settings> Expert Settings I set the Experts Records per Page to 1 (it also is now defaulted to 10).

    Fifth, In Jobs > Settings > Custom Layout I selected 1 lg block for both the Jobs, and the Experts fields.

    In Jobs > Settings > Experts Demo Data under "Dummy Experts Amount" I selected 0, and I unchecked "Sample Files" (If you want the dummy experts to have sample file check this box).

    I hit submit.

    Looking at the Jobs > Manage Jobs I see 10 dummy jobs plus the one sample job I created. Rinse and repeat at least 5 times with same results.

    My target is one sample job, and one sample expert on the page.

    Hope this helps.

    Thanks again for looking into this.
    Robert Miller

  • Ash
    • WordPress Hacker

    Hello @Robert

    I hope you are well today.

    I am sorry for the delay. I have followed every steps you mentioned earlier. Even I have tried in many ways, but it never created that many jobs in my site.

    Would you please grant support access from your Dashboard > WPMU DEV > Support > Support Access so that I can check?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    I will be happy to take a look :slight_smile:

    Cheers
    Ash

  • Ash
    • WordPress Hacker

    Hello @Robert

    I hope you are well today.

    In Jobs > Settings > Experts Demo Data under "Dummy Experts Amount" I selected 0, and I unchecked "Sample Files" (If you want the dummy experts to have sample file check this box).

    I have done the exact same steps you described.

    Selecting "Dummy Experts Amount" to zero should not create any dummy experts, and it didn't create in your site.

    Then I put 1, and then it created 1 expert.

    But in any cases, I didn't see any jobs are created.

    If I am missing something, would you please make a screencast? It will be very helpful to track it down.

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.