How can I redirect a Specific Page URL for SSL Purposes?

Team WPMU,

I have a multisite network set to provide subdomains, with WPMU Domain Mapping, MarketPress, and Infinite SEO (as well as others) installed on the site, as well as a wildcard SSL certificate.

One of the members has mapped his domain and wants to take advantage of MarketPress, but does not want to use Paypal. As expected, the wildcard SSL is not carrying through and the force SSL function to utilize a payment gateway is throwing an error — the subdomain address is not. = error = good

I understand why the SSL cert won’t carry through to the mapped domain, but is there a way to disable the mapping for that specific URL so the payment gateway will function properly? The rest of the site does not need to be SSL — just that one page.