How can I refresh my Youtube playlist in my word press site after making a change in the playlist?

Hi,
I am trying to Youtube Channel Gallery plugin to show my Youtube playlist like this one, http://englishjump.net/653/ Youtube Channel Gallery seems to work all right to show Youtube playlists.

However, when I added new video to my youtube playlist, the new video is not reflected or updated to http://englishjump.net/653/ . It just shows previous playlist without showing an added video at the end of the playlist.

I used the following Youtube Channel Gallery plugin shortcode.

[Youtube_Channel_Gallery feed="playlist" user="PL6RgedeYigOhMoZPc7XIk8XkHC4C-CDTz&index=1" videowidth="580" ratio="16x9" theme="light" color="white" autoplay="0" rel="0" showinfo="0" maxitems="16" thumbwidth="277" thumbratio="16x9" thumbcolumns="2" title="1" description="0" thumbnail_alignment="top" descriptionwordsnumber="6" link="1"]

And the "PL6RgedeYigOhMoZPc7XIk8XkHC4C-CDTz&index=1" is my Youtube playlist. What I don't understand is that although I make a change in my original Youtube playlist, it is not reflected onto my post where I inserted the shortcode above.

What can I do if I want the changes in my original Youtube playlist to be updated to my youtube channel gallery post?

Thank you in advance.

  • Adam Czajczyk

    Hey Jeonghun,

    I hope you're well today and thank you for your question!

    I think this behavior is most likely cache-related. Try changing your shortcode to:

    [Youtube_Channel_Gallery feed="playlist" user="PL6RgedeYigOhMoZPc7XIk8XkHC4C-CDTz&index=1" videowidth="580" ratio="16x9" theme="light" color="white" autoplay="0" rel="0" showinfo="0" maxitems="16" thumbwidth="277" thumbratio="16x9" thumbcolumns="2" title="1" description="0" thumbnail_alignment="top" descriptionwordsnumber="6" link="1" cache="0"]

    Also make sure that the "maxitems" attribute value (currently set above to 16) is higher than the number of videos in your playlist.

    If you're using any caching plugins (e.g. W3 Total Cache) it might be also necessary to deactivate it or just exclude playlist's URL from caching, if possible.

    I hope that helped!

    Cheers,
    Adam

  • Jeonghun

    Hi, Adam. Thank you for the answer.

    The part, 'index=1' in "PL6RgedeYigOhMoZPc7XIk8XkHC4C-CDTz&index=1" which you gave me above didn't work. Therefore, I deleted 'index=1' and I inserted the following. Then, it worked.

    [Youtube_Channel_Gallery feed="playlist" user="PL6RgedeYigOhMoZPc7XIk8XkHC4C-CDTz" videowidth="580" ratio="16x9" theme="light" color="white" autoplay="0" rel="0" showinfo="0" maxitems="16" thumbwidth="277" thumbratio="16x9" thumbcolumns="2" title="1" description="0" thumbnail_alignment="top" descriptionwordsnumber="6" link="1" cache="0"]

    Can I ask the role of 'index=1' although it didn't work?

    And what's the role of the code 'cache="0" at the end of the shortcode?

    Thank you.

  • Adam Czajczyk

    Hey Jeonghun,

    I'm glad I could help!

    Actually, that "index=1" part is in the code you provided in your first post :slight_smile: I'm not sure what it means exactly but I presume that it selects the first movie of the playlist. However, it's great that the code works without it!

    As for cache=0 it's role is to disable plugin's cache. By default plugin doesn't read playlist content from YouTube servers at each reload of the site, instead it just uses data stored in a temporary file (or temporary database field). This is mainly for speed and bandwidth preservation. The major drawback is that when you update your playlist on YouTube those changes aren't reflected on the site because the plugin doesn't even know about them.

    Caching isn't "eternal" and it expires within a period of time, so ultimately the playlist would be updated. Thus, switching it off forces plugin to read playlist's content from YT servers everytime.

    I hope that helped!

    Cheers,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.