How can I set fixed appointments ?

I have an other question. I can't arrange the appointments I need
I would like to set:

4 appointments only:
30mn preparation 9h30-10h30
appt 10h-11h
30mn prep 11h-11h30
appt 11h30-12h30
break 12h30-13h00
appt 13h30-14h30
30mn prep 14h30-15h
appt 15h-16h

How can I do?

Thanks for helping.
@shelvene

  • PC
    • WPMU DEV Initiate

    Hello Shelvene,

    Greetings and thanks for posting on the forums.

    Appointments plus does not allow you to break down your day in multiple sections however there is a concept of Dummy service providers which you can use to easily achieve this.

    You just need to create users as below

    1: Main service provider - Working hours 10h-11h
    2: First Dummy : Working hours 11h30-12h30
    3: Second Dummy : Working hours 13h30-14h30
    4: Third Dummy : Working hours 15h-16h

    Then you can simply show them up on a calendar where only 4 hours will show up for booking.

    As you will assign all 3 dummy providers to the main provider, all your appointments will be handled by you.

    I hope that helps. Please feel free to ask if you have more questions on the same.

    Cheers
    PC
    Sales &Support

  • pxwm
    • WP Core Meltdown

    Hi @shelvene

    You shouldn't have to add any additional shortcodes or amend existing shortcodes in your appointment page

    Could you please confirm if you have completed the setup as per PCs post above?

    If so could you please provide a screenshot of all the settings in the following tabs:-

    'General'
    'Services'
    'Service Providers'
    'Working Hours' for each service provider

    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @shelvene

    I've checked your settings and I think I've identified the problem.

    In the A+ 'Working Hours' tab could you set the Break time to 'No' for every service provider.

    Currently you only have your 'real' service provider available for booking appointments.

    This should then open up the available time in the calendar.

    Is it also possible to screenpost the 'services' tab so I can check the settings.

    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @shelvene

    I still think you have a problem with the 'Working Hours' tab.

    Could you please check the following:-

    log-in to Wordpress as Admin
    select A+ settings
    select 'Working Hours' tab

    I'm not sure if you allow appointments to be made for 'no specific provider'
    If you do then select 'no specific provider' from the 'List for:' dropdown
    Then set the 'Work' dropdown to 'Yes' for the appropriate days
    Then set the item accordingly
    Leave the 'Give Break' dropdown as 'No'
    Then select 'marie' from the 'List for:' dropdown and repeat the same.
    Then do the same for all the service providers real and dummy.
    Then save the settings.

    Hopefully this will resolve your problem.

    If you confirm the settings are already as suggested then I would be more than happy to check the settings on your website if you are in agreement to provide me with a temporary Wordpress admin access.

    If so please let me know and I can provide you with an email address.

    Regards
    SteveB

  • PC
    • WPMU DEV Initiate

    Hey Steve,

    Thanks for being on top of this one buddy. I am totally stumped here coz there are a lot of plugins active on the site.

    I am away for sometime but will be back soon. Lets see if shelvene is fine with me disabling the other plugins too (there are 2 threads going on separately)

    Cheers
    PC
    Sales &Support

  • pxwm
    • WP Core Meltdown

    Hi @shelvene

    I've checked your settings and I can confirm that the 'Working Hours' were set incorrectly.

    To confirm you had set the break times to the same as the working time and this is why no times would be available in the calendar.

    Did you do this to add 30mins to the appointment?

    If you did A+ doesn't work that way so you would have to set the working hours for each service provider to match your appointment time.
    e.g. 09:30 - 11:00 with no break time set

    However I have noticed in a recent post of yours you have posted a problem where you are experiencing a fatal error on the appointment page with a time out.

    Could you please confirm what changes were made to cause this error?
    I ask because I'm assuming in an earlier post you posted a screenshot of your appointment calendar so I'm assuming at some stage the appointment page was working.

    Do you know if the theme has been reverted to the default twentyten as I notice you have a child theme that isn't active?

    https://premium.wpmudev.org/forums/?bb_attachments=450914&bbat=27941

    Regards
    SteveB

  • shelvene
    • Design Lord, Child of Thor

    Hi Steve

    "Could you please confirm what changes were made to cause this error?": I add working hours for "No specific providers" 9h30-16h30. I delete.

    Now I'am trying to set correctly the working hours. I confirm you that I "do this to add 30mins to the appointment"

    Below what I need:

    4 appointments only: (I need 30 mn to prepare each appointment)
    30mn to prepare 9h30-10h
    appt 10h-11h
    30mn prep 11h-11h30
    appt 11h30-12h30
    break 12h30-13h00
    30mn prep 13h30-14h00
    appt 14h-15h00
    30mn prep 15h-15h30
    appt 15h30-16h30

    Yes the theme has been reverted to the default twentyten there are already a few months. I don't have time to make the child them working now.

    Regards

    Côme

  • shelvene
    • Design Lord, Child of Thor

    Hy,

    I set:
    first service provider 9h30-11h
    second 11h-12h30
    third 13h-14h30
    fourth 14h30-16h

    no break time
    and nothing for "No specific providers".

    Always the same problem.

    What do you think if a delete A+ and reinstall ? I can try.

    Thanks

    Côme

  • shelvene
    • Design Lord, Child of Thor

    Hy,

    I set:
    first service provider 9h30-11h
    second 11h-12h30
    third 13h-14h30
    fourth 14h30-16h

    no break time
    and nothing for "No specific providers".

    Always the same problem.

    I will remove A+ and reinstall .

    Thanks

    Côme

  • pxwm
    • WP Core Meltdown

    Hi @shelvene

    I'm aware from your other post that the problem with the time difference has been resolved by deactivating the BackupWP plugin but just want to check if you are still having the problems with appointment times still not being available?

    If so I'll have another look at the settings.

    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @shelvene

    Good news - I've just checked your settings and I've found the problem.

    You were missing a shortcode [app_service_providers] in the appointment page.
    I've added and it appears to be working.

    However adding this shortcode will add a dropdown box to select your service providers with the 'no specific provider' showing all dates and times as unavailable.
    You may wish to make changes to the 'real' and 'dummy' service provider names and you may want to decide what to do as currently you have 4 service providers that relate to your 4 appointment slots so not sure if this is what you want. There are solutions to this we may wish to discuss.
    I would suggest there are other settings you may wish to change once the calendar is working.

    To confirm not all the dates are currently showing available for each service provider as you have a number of appointments in the 'Reserved by GCAL' appointments tab.
    I haven't deleted as I wasn't sure if these were test or 'live' appointments.

    Please let me know if I can delete or if you want to delete from your google calendar.

    I have changed the 'Working Hours' to reflect a 1hr30 time slot for each appointment otherwise setting them as 1hr would have allowed appointments to have been made at 9:30 or 10:00.

    Please let me know if I can delete the reserved appointments or if you are going to delete from the goolge calendar and then I can fully test.

    Regards
    SteveB

  • shelvene
    • Design Lord, Child of Thor

    Hi Steve,

    Thanks for all you do for me : -:slight_smile:

    You can delete the reserved appointments (just test).

    I have change the service providers (other name) but this don't work.
    Can you have a look?

    Merci.
    Côme

  • pxwm
    • WP Core Meltdown

    Hi @Côme

    The reason it wasn't working was because you had set all 4 x service providers as 'dummy' whereas you need one to be a 'real' service provider.
    You also hadn't assigned the 'dummy' service providers to a 'real' service provider.

    I've also changes the calendar schedule to weekly

    It is working but I am refining some of the settings so it looks better when a user makes a booking.

    I'll keep you updated.

    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @Côme

    Unfortunately without applying some bespoke code to your functions.php file (part of the theme) it will not be possible to setup a start time on the half hour without the calendar schedule looking odd.

    Is it possible that all the appointments could either start on the hour or half hour because at the moment some start on the hour and some on the half hour?

    Therefore could they either be:-

    e.g. 10hr - 11hr, 12hr - 13hr, 14 - 15hr, 16hr - 17hr

    or 9hr30 - 10hr30, 11hr30 - 12hr30, 13hr30 - 14hr30, 15hr30 - 16hr30

    I can set them on the hour and half hour but this would mean setting the period to 30mins and then the user booking the appointment would see an hour slot even though the appointment would schedule for 60mins

    Hope that makes sense.
    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @Côme

    There is another way to achieve appointments on the hour and half hour but it does include adding some bespoke code tot he functions'php and also having two services.

    The two services would be: consultation on the hour and consultation on the half hour.

    Instead of having a dropdown to select the two services you could have two identical appointments pages.

    One would automatically select the service on the hour and the other appointment page would select the service on the half hour.

    However it would mean managing two appointment pages.

    Regards
    SteveB

  • shelvene
    • Design Lord, Child of Thor

    Hi Steve,

    No, I w'll not manage 2 appt pages.
    If I need to apply some bespoke code to your functions.php file, this is not a pb.

    For the design, can we make something as Gcalendar ?

    Just a question....

    Thanks

    Côme

  • shelvene
    • Design Lord, Child of Thor

    Hi Steve,

    No, I w'll not manage 2 appt pages.

    If I need to apply some bespoke code to your functions.php file, this is not a pb.
    I would like to have all appts on 1 calendar and not to choose in a dropdown list , if possible ???

    Thanks

    Côme

  • pxwm
    • WP Core Meltdown

    Hi @shelvene

    Could you please confirm if you currently use your personal google calendar to manage your appointments?

    If so could you please confirm if all your appointments are still showing correctly?
    You may wish to check if you have recorded some test appointments I created.
    You shouldn't but just wanted to check.

    I ask because I've checked your settings and you have the settings activated in your A+ 'Google Calendar' tab and it may be best if we disabled this during testing as currently it is synchronising both ways between A+ and your google calendar.

    Once confirmed I'll temporarily disable the A+ google calendar then finalise the settings so you have one appointment page and a single service so you can review.

    Could you also please confirm what you mean by:-

    If I need to apply some bespoke code to your functions.php file, this is not a pb.

    Regards
    SteveB

  • shelvene
    • Design Lord, Child of Thor

    Hi Steve

    "Could you please confirm if you currently use your personal google calendar to manage your appointments?"

    Yes, but the Gcal in A+, is a test calendar, its just a copy of my real Gcal.

    "If so could you please confirm if all your appointments are still showing correctly?
    You may wish to check if you have recorded some test appointments I created.
    You shouldn't but just wanted to check."

    Yes, correct. I see 2 appts you created (screenshot for the first).

    Could you also please concan afirm what you mean by:-

    I would say that, if necessary, I can ad a code in the function.php file......

    Regards

    Côme

  • pxwm
    • WP Core Meltdown

    Hi Côme

    Many thanks for your feedback and good news that the GCAL in A+ is just a copy of your personal google calendar.

    Are you okay if I disable the settings in the A+ 'Google Calendar' tab whilst we are testing as it will stop A+ and the copy of your personal google calendar synchronising?

    Also if I need to write some bespoke code to be placed in the functions.php then I can gain access to this file via the Wordpress editor.
    Would you be in agreement for me to do this or would you prefer to add any bespoke coding?

    However even if you are happy for me to change I would ask you to take a full back-up of the site and the database before making any changes. Is that also okay?

    Regards
    SteveB

  • pxwm
    • WP Core Meltdown

    Hi @PC,

    Just a quick update.

    All the problems have been resolved except the issue with GCAL not synchronising in both directions.

    I've proved it isn't the google calendar settings and I've deactivated all the plug-ins and reverted to the default theme.

    At the moment the GCAL settings are set so it only synchs from A+ to their google calendar and this works fine.

    I suspect their problem relates to either the server or the build of the website.
    I would suggest there are only two options left and that is: Host on a known good server that works with A+ and the GCAL settings so this will prove the server and if this still fails then the only option would be to rebuild the website on a clean Wordpress installation (last resort)

    I'll keep you update

    Regards
    SteveB

  • PC
    • WPMU DEV Initiate

    Hey Steve,

    Thanks for being on top of this.

    I would suggest there are only two options left and that is: Host on a known good server that works with A+ and the GCAL settings so this will prove the server and if this still fails then the only option would be to rebuild the website on a clean Wordpress installation (last resort)

    I can set you up with a cpanel account on my VPS should that help in testing ? Please let me know and I will set it up in no time and as you have all the details for @shelvene you can simply move the site over to that VPS and see if it's the server or WordPress ?

    Cheers
    PC
    Sales &Support

  • pxwm
    • WP Core Meltdown

    Hi @PC

    Final update:-

    I've been assisting shelvene offline and this is the final update to the A+ and GCAL not synchronising and causing duplicate 'pending GCAL appointments'.

    The problem appears to be due to the

    Using phpmyadmin, please connect your database and check wp_app_appointments table structure. gcal_ID field should be set as UNIQUE.

    as per post: https://premium.wpmudev.org/forums/topic/gcal-integration-duplicate-appointments

    Is it possible to include this solution in the A+ faq tab

    To confirm this thread can now be closed as resolved.

    Regards
    SteveB

  • PC
    • WPMU DEV Initiate

    Hello Steve,

    Greetings and thanks for your post.

    First of all, its been a great work you did for the community :slight_smile: Just sent a few more points your way :slight_smile:

    I hereby Declare you as "Appointments+ Champ !"

    I have sent a note to our lead developer @Vladislav so that we can look into it and get this fixed and added to the FAQ's as required.

    Cheers
    PC
    Sales &Support

  • PC
    • WPMU DEV Initiate

    @shelvene

    Just to confirm that everything is now fine and sorted out for you. Kindly feel free to mark the thread as "Not resolved" and make a post if you need further help :slight_smile:

    Cheers
    PC
    Sales &Support

  • pxwm
    • WP Core Meltdown

    Hi @PC

    Many thanks for the points - much appreciated.

    I'm still assisting @shelvene offline as we have upgraded to v1.3 and making some setting changes to improve the functionality of the appointment page.

    I'll keep you posted.

    However there is one question I would appreciate if you could ask @Vladislav and that is:-

    He indicated in one of his recent posts during the 1.3 Beta version phase that he would consider adding functions/hooks so additional/new fields could be added to the appointment form that could also be saved to the database. I can't find any reference to this in the history file and just wanted to check if this feature was added and if so could he provide the code?

    Many thanks
    SteveB

  • Vladislav
    • Dead Eye Dev

    Hello,

    About the adding new fields, I started to work on that for the v1.3 release, but then I realised we'd need to refactor a *lot* of javascript to support this properly. Of course, this will need to happen in the future development anyway, but for v1.3 I realised I have been sitting on a lot of new features (and, more importantly, bugfixes) for quite a while, pretty much holding up on our users that didn't want to use a Beta. So, unfortunately, this is one of those things I really wanted to put in this release but it just didn't make it in just now. I'll stay at it for the next release though, as I do realise everyone's usage model is different which makes that one of the more important features for this kind of plugin.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.