How can remove protected access to a category?

After multiple attempts it appears that the only way for me to remove protection from a category is to disable the Protected Content plugin.

Although it shows that "Everyone" has access, it is displayed under the "Protected" section when filtering the category list.

Thanks in advance for any assistance!

  • Ash
    • WordPress Hacker

    Hello @jaredloman

    Welcome to WPMU community!

    I hope you are well today and thanks for asking the question.

    You can just click on the cross icon in the membership label in the category protection page, please check screenshot. This will remove the protection for a specific category.

    Please let me know if I am missing anything.

    Cheers
    Ash

  • Ash
    • WordPress Hacker

    Hi there

    This is because you don't have any post under this category. Please assign a post in that category and view the link again :slight_smile:

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers
    Ash

  • jaredloman
    • Flash Drive

    Thanks Ash,

    That is very interesting behavior. It does seem to be working different now then it was previously. Prior to now it was just automatically redirecting to the /register page, but now it seems to appropriately show the protected content page.

    Is it possible to protect all posts within a given category (e.g. Digital Editions) but not the category listing page it self?

    In other words, I'd like people to still be able to see the posts listed but once they actually try to view one it should offer the registration page. Ideally, I would prefer not to manually protect each individual post but if that's the only way, I'm okay with it.

    Thanks,
    -Jared

  • Ash
    • WordPress Hacker

    Hello @jaredloman

    I hope you are well today.

    That's not possible out of the box. What you can do is to use more tag protection. You need to set a more tag in those posts (category needs not be protected). So, from Protected Content you will give access to a membership for the more tag, and other users can't see the content below the more tag.

    Hope it helps :slight_smile: Please feel free to ask more question if you have any.

    Cheers
    Ash

  • jaredloman
    • Flash Drive

    Hello there,

    My plugin seems to have returned to the previous behavior of not displaying a category page (http://www.hornsandhookstv.com/category/digital/) and I have confirmed that the category is not protected and that there is a post associated with it.

    I'm beginning to get the feeling that I either don't understand how to properly implement this plugin or that it is a bit quirky... Hopefully it's me :slight_smile:

    Any assistance would be greatly appreciated!

  • Ash
    • WordPress Hacker

    Hello @jaredloman

    I hope you are well today.

    Are you using older version of the plugin? If yes, please update the plugin to latest and check it that makes any changes.

    If not, please enable support access again and I will take a look :slight_smile:

    Cheers
    Ash

  • jaredloman
    • Flash Drive

    Hi Ash,

    At the time of posting I was in fact using the most up to date plugin but I see that some updates have been made since then. I went ahead and updated the plugin and have confirmed that the same behavior persists.

    One thing of note is that although the category itself isn't protected, the one post that is attached to the category is protected. I assumed that the category listing page would still show the excerpts and thumbnails but perhaps this isn't the case?

    Support access has been extended :slight_smile:

    Thanks!
    -Jared

  • Ash
    • WordPress Hacker

    Hello Jared

    I have spent hours but could not replicate it in my test site :slight_frown:

    One thing I noticed that, when I visit http://www.hornsandhookstv.com/category/digital/ page, I can see two posts in there but in admin I can see only one post under that category. Ohh in this page I can see another post from Fishing category, it made me confused!

    Would you please run a plugin conflict test? Please deactivate all plugins (and activate default theme) except this one and check if you still face the problem. If not, then enable one by one and check which one is causing the problem. You can see the flowchart here: https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Please let me know what you get.

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.