How come Snapshot freezes when it gets to backing-up plugins?

I purchased the Snapshot plugin and the first two times I used it it worked fine. Now,however, when I attempt to create a "Snapshot", it freezes when it gets to;
Files: : plugins/snapshot (this is where it froze today).

I didn't change any settings so I'm a bit confused.

Any help you can give will be greatly appreciated.

Ma[x]2

  • Jack Kitterhing
    • Code Norris

    Hi there @maxx1968

    I hope you are well today.

    Has anything changed about the install at all since it was originally working? I know you say no settings have been changed, but have any plugins been added, themes etc?

    When it freezes, does it completely freeze and not complete the snapshot, or does it unfreeze and complete the snapshot?

    How big is the snapshot that your trying to take?

    Thank you!

    Kind Regards
    Jack.

  • maxx1968
    • WPMU DEV Initiate

    Jack,

    I uninstalled the plugin and reinstalled it, then I shut-off my maintenance mode plugin and it worked.

    So i think it was maintenance mode that was somehow causing it to freeze.

    I'll keep you posted if there are any other problems or if it freezes again.

    Thanks - Ma[x]2

  • Paul
    • The Green Incsub

    @maxx1968,

    Yeah, might have been a conflict. Thanks for letting us know. I'm assuming you are running Snapshot in interactive mode. Would probably not have the same issue as a scheduled backup. As always let us know if you run into other issues.

  • maxx1968
    • WPMU DEV Initiate

    Okay, so I spoke to soon.

    Snapshot is NOT working correctly.

    I can successfully create a backup of my databases, but when I try to do a backup of my media the plugin freezes and something strange happens...the side kinda winks out for a split second and the menu bar to the left is messed-up and the page turns grey.

    See images 1 & 2.

    I just don't understand what the problem could be.

    Also I notice my site becomes unavailable and when I check my hosting account, there is a spike in memory usage and entry processes.

    Any idea what I am doing wrong?

    Thanks - Jay

  • Paul
    • The Green Incsub

    @maxx1968,

    For your media files do you have a feel for how much total space is being used?? OR what type of media files? For example if you have some very large movie file the archive process is trying to compress these. Try excluding them from the archive.

    Are you including all file or just media? Try including only one section at a time.

    Also try using the scheduled backups instead of the manual as they tend to use less memory. Just schedule a backup for every 5 minutes. after the first one finishes you can edit the snapshot and turn off the schedule.

  • maxx1968
    • WPMU DEV Initiate

    Paul,

    As far as media files size...it's only 68kb. I just started my site. I use embed codes for my videos, everything hosted by me, using Darkonyx. The actual videos themselves are hosted by my Sponors.

    I have two Snapshots that I created, the first is; Data Backup for my databases and the second is; Media Backup for just my media files.

    I tried the scheduling and it froze. When I clicked on the “Now” link the Snapshot Log Viewer pop-up and it was stuck on Loading...

    See Snapshot 3

    The only errors in my server logs was for a non-existent image and a to report that there was no robot.txt file.

    My Wordpress theme is a “Pinterest” type theme and I think maybe Snapshot isn't compatible with it.

    I just don't know what to do.

    I want a professional backup plugin instead of something free, but I may have to switch.

    Update: I tried deactivating all of my plugins and running Snapshot backing-up just my media files and it still froze.

    Thanks – Jay aka Ma[x]2

  • maxx1968
    • WPMU DEV Initiate

    Here it is in writing, I didn't realize the image would be so small...

    The following table shows version information about your server. When contacting support it might be helpful to provide this information along with your specific issues.

    WordPress Version 3.5.1

    PHP Version 5.3.16

    MySQL Version 5.1.68

    Is Multisite No

    WP_CRON Snapshot uses WP_CRON to run automated backups. If you have disabled WP_CRON via your wp-config.php you will not be able to schedule snapshots.

    WP_CRON Enabled.

    _SESSION Snapshot uses _SESSIONS to store temporary information about database tables and files during the backup and restore processing. Sessions are a default part of PHP.

    Session save path: /tmp

    Session save path is a valid directory.

    Session save path is writeable.

    Folder Permissions Writable (0755) – /wp-content/uploads/snapshots

    Writable (0755) – /wp-content/uploads/snapshots/_backup

    Writable (0755) – /wp-content/uploads/snapshots/_locks

    Writable (0755) – /wp-content/uploads/snapshots/_logs

    Writable (0755) – /wp-content/uploads/snapshots/_restore

    PHP runtime information

    Display Errors 1

    Error Reporting 4983 - E_ERROR, E_WARNING

    Magic Quotes 1

    Max Execution Time (seconds) 1500 The value displayed can be adjusted by Snapshot PHP scripts.

    Memory Limit 40M - WP_MEMORY_LIMIT defined by WordPress wp-config.php.

    Open Basedir Off

    Safe Mode Off

    ZLib Compression Off

  • Paul
    • The Green Incsub

    @maxx1968,

    I'm at a loss as well. Without getting into your site I'm out of ideas. Snapshot runs on the backend so the theme should not effect the processing.

    Maybe 2 more ideas.

    1. On Snapshot > Settings at the bottom is the option to control the zip library used. Default is PclZip which comes with comes as part of WordPress. Try switching to ZipArchive which is native PHP functions.

    2. Also on the Snapshot > Settings toward the bottom is an error reporting section. Controls the error processing and report. Try setting ALL the checkboxes.

    Other than that I'd love to figure out the issue. But would require access to your site. Let me know if that is a possibility.

  • maxx1968
    • WPMU DEV Initiate

    Paul,

    i tried the above to no avail. One thing I have noticed is that when I use Snapshot for backing-up media, it seems to cause a spike in memory usage and entry processes in my server and my site freezes.

    My site is an adult gay site, but if you won't be offended I would be more than willing to give you access to my site and cPanel if need be, just let more how to send you the info.

    Thanks - Ma[x]2

  • Paul
    • The Green Incsub

    @maxx1968,

    Hmm. So does the backup work without the media file selected? Just curious if adding plugins and themes works to completion.

    As for the content, I'm not easily offended. I've probably seen worse. Send access information to

    paul [at] incsub.com

    Not sure I need cpanel access. Really just wp-admin and FTP will work. Just need to get at the Snapshot files in order to add some debug lines so we can see what is happening.

  • Paul
    • The Green Incsub

    @maxx1968,

    I replied the email you sent me but also wanted to reply here in case you get these email notifications faster.

    The FTP account you sent is for a different site. When I look in /wp-content/plugins/I don't see the snapshot plugin directory.

  • Paul
    • The Green Incsub

    @maxx1968,

    Ok. finally got the Media snapshot to finish. Running the manual/interactive just timesout. So set the item to be scheduled once an hour. I know the popup logo doesn't show anything. Not sure on that. But since I have FTP I was able to watch the zip archive being built. That is somewhat where the bottleneck it.

    I tried switching between the PclZIP and ZipArchive with no luck. The zip processing on the images is just slow for some reason.

    Also on the media item you have the destination directory set to the backups folder off the site root. I removed this for now. So the zip files are stored into the default /wp-content/uploads/snapshots/

  • maxx1968
    • WPMU DEV Initiate

    Paul,

    Thank you for your hard work. It seems I may have made some errors in my configurations.

    the media file enlarged because more media was added. I probably should have put the site into maintenance mode for awhile.

    I will Snapshot a check and see how things are going.

    Thanks, again.

    Ma[x]2

  • maxx1968
    • WPMU DEV Initiate

    Good Morning Paul,

    I went in this morning and checked on the Snapshot plugin. What I found was that even though you set it to run once an hour at 7:31, it didn't.

    You can view the included images to see that it only did the one Snapshot that you ran and that's it.

    At this point I think we have spent a great deal of time and energy trying to get a plugin to work and it simply will not.

    The site had visitors and new content was added but nothing triggered a backup.

    I just don't know what to do now.

    Any suggestions?

    I'll check back later – Ma[x]2

    Included images: 6, 7 & 8

  • Paul
    • The Green Incsub

    @maxx1968,

    Actually the snapshot scheduled item DID run. I was just checking via FTP and see the files. But cannot figure out why snapshot does not update its registry with the new archive entry. Something strange is going on for sure.

    See the attached image. All the 100+Mb zip files are the media backups.

    Over the night I had that snapshot entry running hourly. This morning I changed it to once daily. From what I can tell for the hourly runs it takes roughly 20 minutes to complete the backup which is way longer than is should for a 100Mb archive. Disk processing on your site just seems slow. Not familiar with the hosting.

    But I wanted to continue looking into the issue this morning. Also I noticed when the scheduled backup is running the site does not spike as before. Or at least when I was attempting to run the manual backup I noticed the page gave an error when attempting to reload. I was shown a page from your hosting stating something to the effect the site was down. After a few minutes I was able to refresh the page and get back into wp-admin.

  • maxx1968
    • WPMU DEV Initiate

    Paul,

    I want to thank you for all of your help. After considering everything, I have decided that I don't think this plugin is going to right for me.

    There seems to be something not functioning right and after reading your last reply I think it's best to try for something different.

    Once agin i want to thank you,

    Ma[x]2

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.