How do I change the page tittle from make appointment

How do I change the page tittle from make appointment to a site name?
Also
I can not seem to have service time as follows:
30 min for a 35min time period
20 min for a 25 min block
15. 10....

  • PC
    • WPMU DEV Initiate

    Hiya,

    Greetings and thanks for posting on the forums.

    How do I change the page tittle from make appointment to a site name?

    You can do that via Infinite SEO plugin. Just edit the make appointment page and set the title to whatever you want. See it in action here : http://appointmentsplus.wpdemo.in/make-an-appointment-2/

    I can not seem to have service time as follows:
    30 min for a 35min time period
    20 min for a 25 min block
    15. 10....

    There is an option named as Time base. That is the base value of the time slot and the service duration can only be selected in multiples of that value.

    So multiple duration services can be possible but not multiple time bases. You can set time base to 5 minutes in your case and then service duration in multiples of 5.

    I hope that helps. Please feel free to ask if you have more questions on the same.

    Cheers
    PC

  • PC
    • WPMU DEV Initiate

    Hiya,

    I tried setting the additional time base to 5, but it never shows up under services.. it still goes to 10,20….
    please help.

    Sorry to have not noticed it before,

    If the above time bases do not fit your business, you can add a new one, e.g. 240. Note: After you save this additional time base, you must select it using the above setting. Note: Minimum allowed time base setting is 10 minutes.

    You can however override that under the corefiles which will have to be redone after every plugin update.

    You can change that value in appointments.php file

    Around like 1082-1087

    function get_min_time(){
    if ( isset( $this->options["min_time"] ) && $this->options["min_time"] && $this->options["min_time"]>apply_filters( 'app_safe_min_time', 9 ) )
    return (int)$this->options["min_time"];
    else
    return apply_filters( 'app_safe_time', 10 );
    }

    app_safe_time is the value you need to change

    I hope that helps. Please feel free to ask if you have more questions on the same.

    Cheers
    PC

  • Alexander
    • DEV MAN’s Mascot

    Hi @mattbkelly,

    We spoke in live chat today regarding this and I said I would followup here. We normally don't do custom code, but to make this easy for you I've put something toegether to help:

    function app_custom_safe_time()  { return 5; }
    add_filter('app_safe_time','app_custom_safe_time');

    Take that code and add it within a plugin, or your theme's functions.php It will override the default behavior of Appointments+ for you and allow you to use 5 minute as a time base.

    Best regards,
    Alexander Rohmann

  • Mattbkelly
    • WordPress Warrior

    I tried adding

    function() app_custom_safe_time { return 5; }
    add_filter('app_safe_time','app_custom_safe_time');

    To appointment.php under edit plugins in Wordpress dashboard and in gave me an error and deactivated the plugin.
    Did I add it to h wrong area?

  • Mattbkelly
    • WordPress Warrior

    OK. I realized i need to go back to dashboard plugins and activate it. i did than and it gave me an error message:
    plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected '(', expecting T_STRING in /home/content/25/10903625/html/wp-content/plugins/index.php on line 12

  • Alexander
    • DEV MAN’s Mascot

    Hi @Mattbkelly,

    Glad you were able to get this figured out. Something happened with some of our downloads on the forum so some are missing. This code can easily be added within a theme's functions.php or another plugin. Good to hear you got this worked out in PHP

    I don't quite understand what you mean by your next question though. Could you elaborate a bit?

    Best regards,

  • Alexander
    • DEV MAN’s Mascot

    Hi @Mattbkelly,

    Is your site still down? If you edited the code, it sounds like something went wrong and is triggering a fatal error

    If you enable WP_DEBUG mode, you can see what this error is. You can do this by adding this to your wp-config.php file:

    define('WP_DEBUG',true);

    I don't have that plugin file handy, but if you want to send me wordpress login and FTP info, I can take a look at this for you. Just send it over our contact form: https://premium.wpmudev.org/contact/
    - Choose "I have a different question"
    - Include my name in the subject "Alexander Rohmann"
    - Include a link back to this thread
    - Include any relevant login information

    Best regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.