How do I configure WPMU-Nelo so that the custom homepage is displayed as the homepage.

I cannot find a way to configure WPMU-Nelo so that the custom homepage is displayed as the homepage.

I have designed the custom homepage.

I have populated it and saved it and revised and saved it again.

Still, when I enter the URL ( the shown page is an unpopulated blog.

How do I get this corrected?

  • ODM
    • Design Lord, Child of Thor

    The support given by WPMU is stellar. Thanks to all on staff for “being there” when we need help.

    This first response is not adequate for the NELO matter at hand. The problem is NELO specific, I think.

    I can see the custom homepage when I am working on customizing the NELO theme, but I cannot find where it is located. I can edit the page, and watch it change as I make changes, but when I am done I cannot find the custom home page nor can I find how to make it the static page to which the “home page” file points.

    Where is the custom home page is stored?

    By what name?

    How do I cause NELO to access THAT particular static page as the normal home page?

    I realize these are NELO specific questions, and perhaps others more experienced with NELO can advise me on the correct course of action.

    I looked for an implementing manual for NELO on the WPMU site, but cannot find one.

    So that will be a fourth question: Can WPMU make available to me and others a guide for implementing WPMU-NELO?

    I hope you or someone can address these questions.

    Kind Regards,


  • Jack Kitterhing
    • Code Norris

    Hi there Steve,

    I hope you are well today and sorry about the extreme delay with a reply.

    I have just checked this for you and if you download the main zip and then look for a file called index-home.php click on that within that you’ll see the location of the other components for the home page.

    Namely custom-homepage.php in Nelo/lib/templates/wp-templates these are the files you want :slight_smile:

    If we can be of any further assistance please don’t hesitate to ask.

    Again sorry about the extreme delay.

    Kind Regards


  • Barry
    • New Recruit

    I think everyone misunderstood his question.

    The problem is that when you select to use the Custom Page, you DO NOT set the STATIC PAGE option in READING on the NELO theme.. The theme option overrides that setting.

    The problem is, when you choose to use the Custom Page, you have no way of setting another page to be your blog page, so therefore, you end up with ZERO blog, except for the fact you can show XX number of “recent posts” on the front page.

    Ideally, Nelo would work better if your could select the “Custom Page” as your static page and another page as your blog, but that is definitely not how it is designed.

    Still like Nelo for all of its flexibility, but that is one minor annoyance.

    My final solution was to use the custom page option, leave it to show a custom post, and then added the recent posts widget to the right sidebar and the “home top right” area of the theme, so visitors could find my blog posts.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.