how do I create 30-min appointment at 1:45?

I installed appointments+ and it's working. I offer 30-, 45-, and 60-minute services. When I set a break ending at 1:45, it shows 1:30 as AVAILABLE when I have the 30- or 60- minute service selected on the front end. It shows 1:45 available when I have the 45-minute service available (correct). Is there a way to schedule 30- and 60-minute appointments at the 0:15 or 0:45 time slot?

  • pxwm
    • WP Core Meltdown

    Hi @Randy

    If I've understood your requirement correctly and you are using v1.3.1 then the default 'Time Base' is set by the Duration of the Service that has been selected.
    If you want the 'Time Base' to be controlled by the 'Time Base' field in the A+ 'General' tab so Services can be booked at 15 min intervals then you could try the following:-

    Login to your Wordpress dashboard as Admin
    Select A+ Settings
    Select the 'Add-ons' tab
    Activate the 'Durations' Add-on
    Then select the 'General' tab
    A new field will be visible at the bottom of the 'Time Settings' section
    The new field is 'Time slot calculus method'
    Set this to 'Minimum time based appointment duration calculus (legacy)'
    Set the 'Time Base' field to 15mins
    Save the settings.

    This should now allow appointment to made every 15 mins.

    Please try making an appointment and confirm if this is the case.

    Hope this helps
    Regards
    SteveB

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.