How do I disable the "No Preference" for service provider choice?

How do I disable the “No Preference” for service provider choice?

http://sanantonio.lavenderskinspa.com

Link: http://sanantonio.lavenderskinspa.com/schedule-a-spa-appointment/

  • Vinod Dalvi
    • WP Unicorn

    Hi Dana,

    Thank you for your reply.

    Currently when there are more than one service providers providing the same service then the by default the service provider drop down displays “No Preference” option and if we remove the “No Preference” option then there should be a service provider which will act as default service provider initially when nothing is selected.

    I will move this over to the features & feedback section. This way it can be considered for future development, and we can also see what other community members think about the feature request.

    In the meanwhile you can change the “No Preference” text to anything else using the empty_option parameter of app_service_providers shortcode as following.

    [app_service_providers ... empty_option="Please, select"]

    Cheers,

    Vinod Dalvi

  • Dana
    • Flash Drive

    Thank you Vinod,

    Technically correct but highly whack. Thanks for moving to the feature and feedback section.

    It’s EXTREMELY frustrating to manage service providers, when the is a ghost in the schedule, because we never know if someone will book with “NO PREFERENCE” selected.

    We will be finding another solution in order to reduce our preventable stress level if this is not fixed with the next rev or the next 30 days. It’s just silly. Imagine a ghost employee in your enterprise that could be committed for a service in your business that NO-ONE could prevent from having an event be scheduled for. No one could ever realx … eh? Not predictable at all.

    Spa Booker is what we are looking at now as it integrates with spafinder dot com websit + marketing opportunities. Please stop me from leaving,.

  • Dana
    • Flash Drive

    Oh your day off. Someone books the “No service provider: at 3pm which happens to be the wedding date and time of your sister and EVEN THOUGH all service providers blocked their schedules……………….Doesn’t matter because some jack-wagon chose “NO PREFERENCE” for service provider and is waiting outside your establishment when everyone has blocked their schedule.

  • Vinod Dalvi
    • WP Unicorn

    Hi Dana,

    Sorry for the late reply here.

    The developer may be busy in other task or missed this thread so i have flagged him again to reply here.

    I think this was the answer this new shortcode does what we need.

    empty_option

    Empty option label for the selection

    Example: [app_service_providers … empty_option=”Please, select”]

    I don’t know what you meant but i have already posted the similar answer in my previous reply.

    Cheers,

    Vinod Dalvi

  • Lars
    • WPMU DEV Initiate

    Sorry to interrupt, but I see the same issue and I cannot see that

    empty_option=”Please, select”

    can be a solution.

    If the user is not selecting a provider then the appointment will be made anyway with no provider selected.

    I see this as a ghost appointment.

    How to require that the user selects a valid provider before an appointment can be made?

  • Ash
    • WordPress Hacker

    Hello Guys

    To remove that text totally, you need to edit the plugin core files. Please go to /wp-content/plugins/appointments/includes/class_app_shortcodes.php line no 1324 and look for:

    if ( 1 != count( $workers ) )
    $s .= '<option value="0">'. $empty_option . '</option>';

    Remove these two lines.

    Please note that, this changes will be lost in next update. So it’s worth to note down this changes somewhere and apply again after your updates.

    Hope it helps :slight_smile: Please feel free to ask more question if you have.

    Cheers

    Ash

  • Vladislav
    • Dead Eye Dev

    Hello,

    The latest plugin release (v1.4.3, just released) comes with an alternate way of achieving this very thing. The app_schedule and app_monthly_schedule shortcodes now both have a “require_provider” attribute, which will prevent showing of the schedules unless a provider has been selected. There is also the “required_message” attribute, which is the message that will be shown if required service providers are missing. Here are some usage examples:

    [app_schedule require_provider="1"]
    [app_schedule require_provider="1" required_message="Select a provider first"]

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.