How do I edit the "Share this" text? What is it for?

Hello,

[1] I'm not sure what the "Share this" text is for and I don't see any way to edit it in the Settings area.

[2] How do I remove this text if I want to?

See image at link:

http://amson.org/images/share-this-june-14-1.png

Thank you,
Chris.

  • Dharmendra

    Hello Chris,

    I hope you are well today and thanks for posting on the forums.

    I noticed that you are using Jetpack plugin and one of its module called sharedaddy is adding this link.

    So you can disable this module by navigating to Wordpress dashboard ==> Jetpack ==> Settings

    I hope that helps. Please feel free to ask if you have more questions on the same.

    Thank you for being a WPMU Dev Member!

    Have a great day!

  • Chris

    Hello Dharmendra,

    Thank you for your reply.

    I understand your reply, however I need to have that "Sharing" plugin in Jetpack operational with the "Share this" text there.

    Does this mean that I can't use that "Sharing" plugin option in Jetpack with WPMU's "Subscribe by Email" plugin because the Jetpack Sharing plugin will always write that text into the email page of the "Subscribe by Email" email?

    It appears that the 2 plugins are interfering with each other.

    Sincerely,
    Chris.

  • Chris

    Hello Tyler,

    Thank you for your reply.

    Here are 4 files for you from the Wordpress site: blog.chrismson.com

    As you can see, the social media icons at the bottom of the original post show up as a series of vertical black dots in the Subscription email.

    Also the text ( "Share this Post…" ) that sits above the social media icons in the Post shows up in the Subscription email as well.

    I do not need the text ( "Share this Post…" ) or the black dots to show up in the Subscription email.

    As you know this text and the attempt to show the social media icons is coming from the Jetpack "Subscriptions" plugin.

    Jetpack is a very common default package with Wordpress Themes such as this one which is 2014 (3.9.1)

    I would not have thought that there would be be conflict like this between Jetpack and the WPMU "Subscribe by Email" plugin.

    Is there a way to not have the ( "Share this Post…" ) text and these vertical black dots in the Subscription email?

    Sincerely,
    Chris Amson.

  • Chris

    Hello Ari,

    Thank you for your help with issue.

    I appreciate the suggestion and this is something that we can explore, but I need to use a subscribe by mail plugin on 3 different websites.

    It seems strange to me that WPMUDEV's "Subscribe by Email" plugin has conflicts with Jetpack, which is the most common plugin package available and came pre-installed with this 2014 Theme.

    Also, I do not have any experience with coding and installing custom html or css or fixing a problem in the future if the custom code that is added now has any conflicts with what I add to the website in the future.

    My intention was to have a simple plugin that sent Posts via email to a subscriber list without any issues.

    If you create some code to get around this conflict, would this be code that you send to me or do you have to write it into this first website of 3 yourself?

    I will Grant Access now.

    Sincerely,
    Chris Amson.

  • Chris

    Hello Ari,

    I just wanted to add that I currently have the Jetpack - "Sharing" plugin activated and that places the social media icons at the bottom of each Post.

    There is also a another Jetpack plugin that I will be activating, and that one is called "Publicize" which sends my Posts to my Facebook page.

    Could you please test your code with Jetpack - "Publicize" also activated.

    Sincerely,
    Chris Amson.

  • Chris

    Hi David,

    Thank you for your help with this.

    One point I'd like to make is that I am simply using "Sharing" in Jetpack.

    I don't see any reference to "Sharedaddy" in Jetpack.

    I don't see any settings that I can adjust in the plugin that you recommended and I already have control over where the the social media icons display as they can be set inside the Jetpack "Sharing" settings.

    On the the Sharing settings page there is a control that already allows you to set where you want the social media icons to show up and I have that set to Posts as in the attached image called jetpack-sharing-settings-1.png

    I think the issue is that when the post gets carried over to the email in the "excerpt" mode the social media icons are being carried over
    as well but they can't display in the email so they show up as black dot's.

    A solution could be:

    In excerpt mode the social media icons are not carried over to the email but are left out and therefore there would be no black dots.

    Also the "Share this…" text which is also set on the Sharing page of Jetpack would be left out and therefore this words would not show up in the email either.

    I suppose it's down to defining where the excerpt informations stops so that the text and social media icons do not carry over to the email.

    Sincerely,
    Chris.

  • Chris

    Hi David,

    I just wanted to add one more thing…

    Jetpack is a very common Wordpress plugin package, and it is so common that it sometimes come pre-installed with a Wordpress installation, as it did on my Wordpress installation.

    Jetpack "Sharing" allows one to place social media icons at the bottom of Posts or Pages.

    When one decides to send a Post over to an Email by subscription it would make sense to not include the social media icons at the bottom of the Post page, or at least have a control in Subscriptions that says:

    Send social media icons to email: YES / NO

    Just a thought.

    I would have thought that this is a common issue when someone is using WPMU DEV's "Subscribe by Email" on the same Wordpress website that uses Jetpack "Sharing"

    Sincerely,
    Chris Amson.

  • Chris

    Hi David,

    I have tried the "sharedaddy-more-control" plugin that you recommended and there is no change in the issue of social media icons being carried over to the email and showing up as black dots in the email.

    Also, this plugin is not designed for Jetpack "Sharing" and is also very old.

    There is also a Warning message displayed when it is Activated.

    See attached image.

    Do you have any other possible solutions?

    Chris.

  • Chris

    Hello David,

    I have just created another test situation for the WPMU DEV "Subscribe by Email" plugin:

    You can do this yourself and you will get exactly the same results:

    [1] Create a new installation of Wordpress.

    [2] The default Theme is 2014. Update to the latest version of the Theme if it's called for. Latest version is 3.9.1

    [3] If Jetpack is not installed, install it. The latest version is 2.7.5

    [4] Upload and activate "Subscribe by Email" plugin.

    [5] Activate "Sharing" plugin in Jetpack.

    [6] Select a number of social media icons to display at the bottom of Posts page.

    [7] In the Sharing settings, choose to display social media icons on Front Page and also in Posts.

    [8] Add a Subscriber to the "Subscribe by Email" plugin.

    [9] Create a Post and Publish it.

    [10] Check email for the Subscription Post and it will look like the image below.

    You can follow the above installation and you will see the results every time. Test it on 1000 Wordpress installations and you will see these symptoms every time.

    David, The "Subscribe by Email plugin has a flaw. It does not work with Jetpack "Sharing" without creating an ugly column of black dots in the email.

    I don't have any more time to spend on this. I have earned my $19.00 !

    Please Refund my Paypal payment.

    Sincerely,
    Chris Amson.

  • DavidM

    Hi @Chris,

    Thanks for your replies and also per our email discussion, thanks for posting this possible workaround to the issue.

    I was going to mention that possible solution earlier but assumed you required that particular "Front Page..." option to be on.

    It's not quite an easy matter to resolve otherwise as we couldn't easily find a way to conditionally suppress Jetpack's sharing feature.

    Really glad that disabling that setting works for you and I'll be looking to see if there's a way to suppress that otherwise still.

    Is it okay for me to "Mark as resolved" for now? [EDIT: sorry, I posted this without realizing it'd been closed] :slight_smile:

    Cheers,
    David

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.