How do I fully uninstall the plug-in so that I can modify class_wdfb_widget_albums.php outside of th

Hi,

I'm trying to modify how the facebook album is formatted by making changes to class_wdfb_widget_albums.php

Unfortunately, I can't get even the simplest change to take as this file is showing up as (inactive) in the plugin editor (since I made the first change).

Doesn't matter what I do - I've tried deleting and re-installing. Still no changes are showing up and this file is marked (inactive) no matter what. I even tried installing with the modified file but it is still using the original php. Also, after deleting and reinstalling, the facebook app info is already in the facebook plug in settings.

All of this leads me to believe that it isn't fully 'deleting'.

Is there a step I am missing.

Any help with the actual source of the problem (ie the inactive business) would also be much appreciated, although I still think if I can successfully do an uninstall I should be able to achieve the goal of reformatting the album.

CHEERS,

Greg

  • PC

    Hello Greg,

    Thanks for posting on the forums.

    The best way to edit a plugin is not to do it via the plugin editor in WordPress.

    What I do is I open the website in a browser and open a FTP session along with it and then modify the files and reload the site to see changes.

    The album CSS mods can be done in this file here: wpmu-dev-facebook\css\wdfb_album_editor.css

    But the best way to add custom CSS is to use a plugin like : http://wordpress.org/extend/plugins/imporved-simpler-css/ and add the CSS there.

    If you want to make any changes to functionality, then you are in the right file and should use FTP to make changes to it.

    The plugin settings are saved in the database so as to avoid losing them with plugin updates, if you need to remove them completely, they have to be removed in the db.

    I hope that helps. Please feel free to ask if you have more questions on the same.

    Cheers
    PC
    Sales &Support

  • Steve

    Thanks for the quick reply PC.

    After things went a bit awry through the plugin editor I have actually also tried modifying the file via ftp but it still doesn't get reflected in the site. Very strange. It is also now giving me the error "Plugin could not be deleted due to an error: Could not fully remove the plugin(s) wpmu-dev-facebook/wpmu-dev-facebook.php." when I try to delete the plugin through wordpress (closed my ftp client just in case also).

    I think I might have to dig into the database so any advice on what I should be removing to get the plugin install back to ground zero so I can start over would be much appreciated.

    CHEERS,

    Greg

  • Steve

    Thanks PC.

    This is a strange one. There are no non-wordpress core tables in the database that I can see through phpMyAdmin (see screenshot). Thought that maybe it was just that I couldn't see the tables created by the wordpress instance with my database login credentials so installed a plug in called WPDBSpringClean but it said there weren't any extra tables either.

    I deleted the facebook plug-in via ftp and re-uploaded it via ftp with my changed code. Still is showing the original one. The server MUST be caching it in memory. I haven't installed any caching plug-ins. I am thinking that maybe the host guys have some sort of caching in place.

    Anyway, any ideas that might point me in the right direction would be much appreciated, again...

    Cheers,

    Greg

  • Steve

    Hey PC,

    OK.
    After re-installing wordpress to eliminate the possibility it was issues with the plug-in installation, and much dead-end backtracking I have realized two things:

    * class_wdfb_widget_albums.php is not responsible for formatting the album. It is actually class_wdfb_marker_replacer.php in a function called process_album_code. So, rather than it being that wordpress was caching or preventing my changes from taking hold it was that I was modifying the wrong file. Changes take hold fine by simply changing the code and uploading the new file using ftp.
    * I had also wrongly assumed that the album was failing to show because of my attempted changes. It turns out that it is not consistently showing the album regardless of my changes. The album I want to show is from a facebook page that my login is administrator of (although I didn't create the page). The plugin is logging into facebook with my credentials. When I changed the album id to be an album in my facebook user's login it worked each time. Is this a problem for the plugin (ie showing album's from a page rather than user)?

    So:
    * I want to use [wdfb_album id="196712730369249"] which is an album on a facebook page (as opposed to an album associated with a facebook user). Any ideas why the plugin is flaky for this album and not for an album under my user? I got this id from the url http://www.facebook.com/media/set/?set=a.196712730369249.45476.193670044006851&type=3

    Any assistance will be much appreciated.

    Greg

  • PC

    Hey Greg,

    Greetings and thanks for posting back.

    Sorry for not being able to get back to you any earlier as I was away to see the family.

    Is this a problem for the plugin (ie showing album's from a page rather than user)?

    The plugin only allows an album to be used from a Facebook profile and not a facebook page.

    In order to get more information on this, I will need to get our lead developer on the thread here so that he can provide us a direction.

    Cheers
    PC
    Sales &Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.