How do I get a new Directory to display in the front end of my site?

I created a new content type for new Directory but cannot figure out how to get it show on my site. I set the Capability Type to post and also tried listing. I created the the directory with some custom fields, added items under Support, selected Categories and Tags under taxonomy, set Public to true, show in nav menu is True the added a category and a new directory item but I see nothing on my home page. Why?

Directory shows up in the side menu in the back end but nothing on the front end. Also when I try and preview the new listing from withing the listing item using the Preview Changes button I still get a blank page jsut showing the Edit button.

  • aecnu

    Greetings daviator,

    Thank you for this great question and a significant item to bring up.

    What new content type are you referring to?

    I created the the directory with some custom fields, added items under Support, selected Categories and Tags under taxonomy, set Public to true, show in nav menu is True the added a category and a new directory item but I see nothing on my home page. Why?

    I don't know. We will certainly have to dig a little to figure this out staring with my question above.

    Also what content did you expect to see on the front end? i.e. which in turn reverts back to my first question.

    Please advise.

    Cheers, Joe

  • daviator

    Under Custom Press > Add Post Type I created a new type called ad_dir with the custom fields listed above.
    Under "Supports" I have the following checked: Author, Thumbnail and custom fields.
    Under Support Regular Taxonomies I have Categories and Tags checked.
    Under Capability Type I have tried listing and post. Public is set to true. I have Show UI, Show in Nav Menus, Publicly Queryable all set to TRUE.
    I have my four custom fields all checked.

    I then saw the directory appear in my left admin menu where I also had the options to Add New. So I added a new item to test but that was as far as I was able to get.

    Forgive me if I'm all over the board here but there really isn't much documentation on the plug-in let alone step-by-step instructions on how to create a new Directory.

    What I want/expect to see is a page, post or menu item with my aircraft directory.

  • Arnold

    Directory creates it's own customtype "directory_listing" with all the proper settings as well as two taxonomies, one for listing_categories and one for listing_tags. There's no need to create your own unless you're going to add your own programming to handle it. The plugin is only going to manipulate the custom types that it knows about. You can delete the directory_listing type and it will recreate itself. when you activate the plugin.

    Custom fields would then be associated with the directory_listing post type for use.

  • daviator

    Only this doesn't solve the problem. I successfully reloaded WP and the plugin and just used the default directory. I added 3 additional fields and turned off the Title and Contents fields.

    I can enter listings in the back end but they all appear with the name of Auto Draft in the front end. Also, the front end entry still shows the Title and Contents fields.

    Also, there are no entries showing under the Listings menu and the listings under My Listings all say Auto Draft.

    Also, there is no way to display the image correctly You either see the tine and cropped thumbnail or when you click on it, a cropped image in the header.

    And yes, i have tried the template that came with the plugin only that is worse as it's CSS appears to be all out of place and the side menus are overlapping the page.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.