How do I get CustomPress to post to the page I want?

I am working on a food site locally and I want to be able to post recipes to http://www.mysite.com/recipes. I setup CustomPress but it posts the recipes to http://www.mysite.com/blog/recipes. How do I fix this?

  • Imperative Ideas
    • HummingBird

    Hey Charles,

    Your problem is that what we call “the loop” is including regular posts and custom post types in its output. We will need to know more about your site in order to help you.

    WPMU Gods: Some sort of wpmudev replicant of loop buddy would be really, really, really helpful right now.

    Charles.

    /blog/recipes is showing the recipes category, not the custom post type. WPMU.org actually has a pretty good beginner’s tutorial on this.

    https://premium.wpmudev.org/blog/easy-guide-to-displaying-custom-post-types-in-your-wordpress-theme/

  • Charles
    • Design Lord, Child of Thor

    Thank you Imperative Ideas, I was able to get things working properly although I am not sure what I did to make that happen. I am using iThemes and have Loop Buddy which until now I never knew what Loop Buddy did. Thanks for mentioning it because now I have even more tools set things up they way I want.

  • Charles
    • Design Lord, Child of Thor

    I came across another issue just now, not sure if its a CustomPress issue or something to do with LoopBuddy. I deleted a test post and it is still showing up on my “recent recipes” widget on the front page, on the recipes page, and when I click on it shows up like a regular post that was never deleted. I trashed it then deleted permanently, or so I thought. Does it have something to do with the archive setting in CustomPress?

  • Charles
    • Design Lord, Child of Thor

    I am still having issues with CustomPress doing what I would like it to do. When I set up my recipes post type I selected true for has archive and rewrite and put the slug as recipes. My recipes page shows up like the first screenshot which I not the way I want me page to look. The categories on the bottom should only be on my front page so that is a problem too. When I go back and change both setting to false I get the second screenshot as a result which is what I want. My blog page, my recipes page, and my videos page should all have the same layout as they are all using the same layout in iThemes. The problem comes in when I go through the same steps for the videos post type. When I get that page looking the correct way screenshot three is what shows up on my recipes page. For whatever reason I can only get one page to show up correctly.

  • Charles
    • Design Lord, Child of Thor

    My screenshots didn’t all upload. So the first one is the way I want things to look, the second one is what happens after I make the videos page look right, the one in this post is what happens what I start things off.

  • PC
    • WPMU DEV Initiate

    Greetings and thanks for being a great community member.

    We haven’t heard from you on this one for long and I am doing a regular followup to see if there is still something we can assist you on this thread.

    Just to manage the support issues more efficiently, I am marking this thread as resolved for now however this is not being done to avoid your questions in any ways.

    Please feel free to mark this is “Not resolved” in case you have further questions and we would be back on it.

    Thanks a lot for being with WPMU DEV.

    Cheers

    PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.