How do I get the Authorize.net button to show up?

I'm trying to use Authorize.net as a payment gateway for the membership plugin and the payment button is not showing up on the subscriptions page. I've noticed there are a lot of support topics for this question so I've run through the troubleshooting steps suggested in the earlier posts including:

1) disabling all other plugins
2) switching to the TwentyTwelve theme
3) ensuring I have active subscription plans/access levels
4) reentering the Login ID, API key, MD5 hash
5) ensuring that SSL is enabled

This is the first of several questions I have but it's definitely the most critical. Thanks for your help.

I don't know if this matters but under the subscription label this text shows up: "You will pay : &USD;100.00 every month". Obviously it would also be nice to get rid of the ampersand and semicolon as well.