How do I integrate a new blog template with my WHMCS?

Hello,

How can I integrate a new blog template with my WHMCS?

Right now, I have the Pro Sites plugin integrated with WHMCS. But I want to offer a template as well.

Do i upload the template on WHMCS since I don't think I can add the template to Pro Sites, correct?

Any information will be appreciated.

Thanks!
Janet

  • Tyler Postle

    Hey there Janet,

    Hope you're doing well today :slight_smile:

    Only setting the 'default' blog template currently integrates with WHMCS. So, when the site is created through the WHMCS sign up, it will apply the default template.

    For a selection of templates, the sign up needs to happen through WordPress.

    I've attached a screenshot to illustrate how to choose the default template that will be applied :slight_smile:

    Hope this helps Janet!

    Let us know if you need any further assistance.

    All the best,
    Tyler

  • Janet

    Hi Tyler,

    So, I will make the template default once the template has been created?

    I started the process of making the template and did not see the setting above.

    Please let me know at what stage of template creation the setting above appears.

    Also, the copy of the subsite that I got from copying my single site with the snapshot plugin, is re-directing to the single site domain's name.

    So, the sub domain appears but then it re-directs to the domain of the single site. I did get an error when the snapshot was created that the URL did not match.

    How can I fix this issue as well.

    Thanks,
    Janet

  • Tyler Postle

    Hey again Janet,

    So, I will make the template default once the template has been created?

    Yes, so once the template has been created then hover over the template in your template list and select "make default".

    Would you mind granting support access so I can make sure a template was correctly set as default?

    Also, the copy of the subsite that I got from copying my single site with the snapshot plugin, is re-directing to the single site domain's name.

    I've responded on your thread here: https://premium.wpmudev.org/forums/topic/need-help-with-snapshot-plugin#post-801654

    Look forward to hearing back on both issues Janet. Talk to you soon!

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.