how do I create forms etc for the affiliate plugin?

Hi there and happy new year :slight_smile:

I would like to use the 'affiliate' plugin for my site, but am struggling to figure out how I manage to allow people to become affiliates for my site. Is there a way to make it possible for people to register on the front end of my site?

thanks in advance
Linda

  • Adam Czajczyk
    • Support Gorilla

    Hello Linda,

    I hope you're well today and thank you for your question!

    On Multisite you enable/allow registration for entire network and the "Network Admin" settings is a right place to do this. If you already enabled it there, the registration of new users should work everywhere on your site.

    I understand though that the one that doesn't work comes from the shortcode provided with the theme. Sometimes, theme developers include their own registration procedures and there's a good chance that it may not follow properly WordPress Codex. There's also a chance that it's not an issue with improperly developed plugin but caused by some conflict or particular setting that we are not aware of yet :slight_smile:

    That said, would you mind granting me a support access to your site so I could take a closer look at it and check it? You may do this by following this guide here:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please also let me know about what is the shortcode in question and where exactly (what page/post/sub-site) would you want to put it on.

    Happy New Year!
    Adam

  • Linda
    • Site Builder, Child of Zeus

    Hi there Adam

    You're such a star, thanks for your advise :slight_smile: I would absolutely LOVE if you could take a look at it, but at the moment my hosting company is hard at work because I have actually managed to lock myself out of my own site. I finally realized that I needed to go to the network admin section to set up so that people could register. When I did that the short code registration code worked just fine, but in order to test it I had to log myself out from the site...don't know what I did wrong but when I went to log in again I couldn't :slight_frown: but I will certainly return when it is up and running again because I think I might have gotten myself into deep water.

    Kind regards
    Linda

  • Predrag Dubajic
    • Support

    Hi Linda,

    Ouch, sorry to hear you got locked out of your site :slight_frown:

    For future testing I would suggest using incognito mode in your browser, this will open new window where you will not be logged in but on your original window you will be logged in as admin, so now use incognito mode to access as visitor.
    Incognito mode for Chrome: https://support.google.com/chromebook/answer/95464?co=GENIE.Platform%3DDesktop&hl=en
    Incognito mode for Firefox: https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history

    Let us know if you need any further assistance once you have access to your site again.

    Best regards,
    Predrag

  • Linda
    • Site Builder, Child of Zeus

    Hi there Predrag

    thanks for this SUPER tip :relieved: thankfully my hosting company has resolved my issue, but feel a lot better now I know about the incognito solution. I was really nervous about testing the registration form, up until I saw your reply, thanks a mil :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.