How do I really delete images and why aren't they really

How do I really delete images and why aren't they really deleted? I upload an image "image.jpg." Then, I delete the image. I create a revised "image.jpg" same filename and upload it. And, the original image still appears. And, this is not a browser cache as I can clear the cache or change browsers and I get the same result. TIA

  • [email protected]
    • Design Lord, Child of Thor

    I enabled my site for you.

    I created a test post.

    I uploaded “image3.png” in the post. I published it.

    I deleted “image3.png” from the media library.

    I created a new image with the same name “image3.png” and uploaded it to the media library.

    It shows up as the same image as the original image, not the new image.

    I go to my test post and delete the original image and select the replacement image (which still appears to be the original image) and the result is the original image.

  • Ash
    • WordPress Hacker

    Hello @prb@skyhoundz.com

    Yes, I can see the issue in your site. This happens because of cache. I can see you have wordfence installed in your site, though I could not delete cache due to file permission error.

    Also, do you have server side cache installed like varnish?

    You need to delete all caches, deactivate caches and check the issue again. If you use CDN or CDN cache, you need to disable them too. Otherwise you have to wait sometime to reflect the changes in the front end.

    Cheers
    Ash

  • aristath
    • Recruit

    Hello again!

    I just logged-in on your site and took a look at your setup.
    I see cache is already disabled on the WordFence plugin so you don't have to disable anything there.
    Are you by any chance using CloudFlare on your site?
    If you are, then you should add an exception for the wp-admin/ section so that it does not get cached.
    Also this may be a permissions issue.... Please make sure that WordPress has permissions to write to the uploads folder and that the owner of these forlders is your webserver and not an FTP user.
    If this site is on a shared host you can contact your host and ask them to fix these permissions for you. If you have ssh access to the site, then you could run this script to fix all folder/file permissions and rights: http://www.conigliaro.org/articles/script-to-configure-proper-wordpress-permissions/

    I hope that helps!

    Cheers,
    Ari.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.