How do I remove Comments on the studio theme?

How do I remove all comments on the studio theme?

  • ckizer86
    • Design Lord, Child of Thor

    Also, if you don't want to go through each post individually, you can use the bulk actions by selecting all posts and selecting "edit" from the bulk actions dropdown and select the dropdown to the right next to "comments" and select "do not allow" that should save some time if you end up doing it that way.

  • ckizer86
    • Design Lord, Child of Thor

    Forgot to mention, if you want the comments to be off by default, you can do this by:

    1. Click on "Settings"
    2. Click on "Discussion"
    3. Uncheck "Allow people to post comments on new articles "
    4. Click on "Save Changes"

  • PC
    • WPMU DEV Initiate

    Hey there @ernest

    Thanks for posting on the forums.

    Wow, looks like @DSafari and @ckizer86 have got this all sorted out :slight_smile:

    Let me know if anything does not work as suggested or you have further questions !

    Cheers, PC

  • ckizer86
    • Design Lord, Child of Thor

    looks like you're having some errors with the quotes. Below, are the errors that are returning. When you're looking at the return from the validator, you will notice that the quote where it's detected looks different than the closing quote. Try typing the quote in the areas that they mention rather than copying and pasting (if you did copy and paste, just replace the areas it detected) If you are entering the embed code, make sure you are in text view rather than visual just to make sure. Try that and see what happens with the errors.

    Line 282, Column 13: there is no attribute "src"
    <embed src= "http://www.youtube.com/v/0pLi0tyLN5U" type="application/x-shockwav…
    ?
    You have used the attribute named above in your document, but the document type you are using does not support that attribute for this element. This error is often caused by incorrect use of the "Strict" document type with a document that uses frames (e.g. you must use the "Transitional" document type to get the "target" attribute), or by using vendor proprietary extensions such as "marginheight" (this is usually fixed by using CSS to achieve the desired effect instead).

    This error may also result if the element itself is not supported in the document type you are using, as an undefined element will have no supported attributes; in this case, see the element-undefined error message for further information.

    How to fix: check the spelling and case of the element and attribute, (Remember XHTML is all lower-case) and/or check that they are both allowed in the chosen document type, and/or use CSS instead of this attribute. If you received this error when using the <embed> element to incorporate flash media in a Web page, see the FAQ item on valid flash.

    Error Line 282, Column 57: there is no attribute "type"
    …//www.youtube.com/v/0pLi0tyLN5U" type="application/x-shockwave-flash" wmode="t…
    ?
    You have used the attribute named above in your document, but the document type you are using does not support that attribute for this element. This error is often caused by incorrect use of the "Strict" document type with a document that uses frames (e.g. you must use the "Transitional" document type to get the "target" attribute), or by using vendor proprietary extensions such as "marginheight" (this is usually fixed by using CSS to achieve the desired effect instead).

    This error may also result if the element itself is not supported in the document type you are using, as an undefined element will have no supported attributes; in this case, see the element-undefined error message for further information.

    How to fix: check the spelling and case of the element and attribute, (Remember XHTML is all lower-case) and/or check that they are both allowed in the chosen document type, and/or use CSS instead of this attribute. If you received this error when using the <embed> element to incorporate flash media in a Web page, see the FAQ item on valid flash.

    Error Line 282, Column 95: there is no attribute "wmode"
    …"application/x-shockwave-flash" wmode="transparent" width="200" height="165"><…
    ?
    You have used the attribute named above in your document, but the document type you are using does not support that attribute for this element. This error is often caused by incorrect use of the "Strict" document type with a document that uses frames (e.g. you must use the "Transitional" document type to get the "target" attribute), or by using vendor proprietary extensions such as "marginheight" (this is usually fixed by using CSS to achieve the desired effect instead).

    This error may also result if the element itself is not supported in the document type you are using, as an undefined element will have no supported attributes; in this case, see the element-undefined error message for further information.

    How to fix: check the spelling and case of the element and attribute, (Remember XHTML is all lower-case) and/or check that they are both allowed in the chosen document type, and/or use CSS instead of this attribute. If you received this error when using the <embed> element to incorporate flash media in a Web page, see the FAQ item on valid flash.

    Error Line 282, Column 115: there is no attribute "width"
    …cation/x-shockwave-flash" wmode="transparent" width="200" height="165"></embed>
    ?
    You have used the attribute named above in your document, but the document type you are using does not support that attribute for this element. This error is often caused by incorrect use of the "Strict" document type with a document that uses frames (e.g. you must use the "Transitional" document type to get the "target" attribute), or by using vendor proprietary extensions such as "marginheight" (this is usually fixed by using CSS to achieve the desired effect instead).

    This error may also result if the element itself is not supported in the document type you are using, as an undefined element will have no supported attributes; in this case, see the element-undefined error message for further information.

    How to fix: check the spelling and case of the element and attribute, (Remember XHTML is all lower-case) and/or check that they are both allowed in the chosen document type, and/or use CSS instead of this attribute. If you received this error when using the <embed> element to incorporate flash media in a Web page, see the FAQ item on valid flash.

    Error Line 282, Column 128: there is no attribute "height"
    …cation/x-shockwave-flash" wmode="transparent" width="200" height="165"></embed>
    ?
    You have used the attribute named above in your document, but the document type you are using does not support that attribute for this element. This error is often caused by incorrect use of the "Strict" document type with a document that uses frames (e.g. you must use the "Transitional" document type to get the "target" attribute), or by using vendor proprietary extensions such as "marginheight" (this is usually fixed by using CSS to achieve the desired effect instead).

    This error may also result if the element itself is not supported in the document type you are using, as an undefined element will have no supported attributes; in this case, see the element-undefined error message for further information.

    How to fix: check the spelling and case of the element and attribute, (Remember XHTML is all lower-case) and/or check that they are both allowed in the chosen document type, and/or use CSS instead of this attribute. If you received this error when using the <embed> element to incorporate flash media in a Web page, see the FAQ item on valid flash.

    Error Line 282, Column 133: element "embed" undefined
    …cation/x-shockwave-flash" wmode="transparent" width="200" height="165"></embed>
    ?
    You have used the element named above in your document, but the document type you are using does not define an element of that name. This error is often caused by:

    incorrect use of the "Strict" document type with a document that uses frames (e.g. you must use the "Frameset" document type to get the "<frameset>" element),
    by using vendor proprietary extensions such as "<spacer>" or "<marquee>" (this is usually fixed by using CSS to achieve the desired effect instead).
    by using upper-case tags in XHTML (in XHTML attributes and elements must be all lower-case).

    What I would do, is on the areas

  • PC
    • WPMU DEV Initiate

    Hey there @ernest

    Thanks for posting back and sorry for the delay in response from staff. I had some family emergency and could not get back to this any sooner.

    Sad to see that my response was not helpful enough and glad that the suggestion by @ckizer86 got this sorted for the comments.

    For removing older comments, here is what we can do as well : http://www.lostsaloon.com/technology/how-to-disable-comments-from-pages-and-posts-in-wordpress/
    http://beta.beantin.se/disable-comments-pingbacks-old-posts-wordpress/

    Also, did you follow the xhtml advice by @ckizer86 ? Did that help ?

    Please let me know if you have more questions and we will be around :slight_smile:

    @ckizer86 : Points your way for your awesome help !

    Cheers, PC

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.