How do I use a shortcode in an Upfront site?

I have a plugin that can work via shortcode in any post or page. I had it working, then the license got wonky so I wound up re-installing it and now I can only get it to work as a widget. The shortcode isn't cooperating. The widget version is quite unsatisfactory. How do I get the shortcode to work again? I've tried the </>, the text box, and the text widget.

Help!

Thank you. :slight_smile:

  • Milan

    Hello amy

    Hope you are well today and thanks for asking us. :slight_smile:

    I had it working

    Did it with Upfront based site ? If yes then how you were using it ?

    You've said, you just reinstalled plugin and now its not working. That's surprisingly interesting behaviour to debug.

    So here is I request you to do. :slight_smile:

    #1) Write down steps here which I can follow on my sandbox site to replicate this issue.
    #2) Grant staff access to your site. Please follow this manual to know how you can grant staff access.
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Looking forward to hearing back. :slight_smile:
    Cheers,
    Milan

  • amy

    Hi Milan,

    I installed the plugin on the Upfront site and entered the shortcode on the page. What I cannot remember is how I got the shortcode in. Could have been just on the page, in a text box, or in a text widget. It was working great and I was quite happy with it.

    Then the dumb license issue came up. I wasn't able to solve it quickly so I deleted the shortcode (a HUGE mistake) and put in a quick "under construction" message.

    I got the license issue fixed and tried to put the shortcode back in and now it doesn't work. I don't recall what I did to make it work. Sorry.

    The shortcode is [monthly-mortgage-calc] and should trigger a very nice mortgage calculator on the page. The one I have there now is the widget version and it's quite brief and unsatisfactory.

    The plugin has not been changed or updated in quite a while, but Upfront was updated which is why I am coming to you with the problem and not the plugin creator.

    I did grant staff access.

    Thanks in advance!

    Amy

  • Milan

    Hello amy

    Hope you are doing well today. :slight_smile:

    I got the license issue fixed and tried to put the shortcode back in and now it doesn't work. I don't recall what I did to make it work.

    Upfront supports shortcode rendering via "Widget" element. :slight_smile: So please,

    #1) Edit the post/page( where you want to render shortcode ). You can view page in browser while logged in as admin, then clicking on "Upfront" menu from admin bar will put in edit mode of that page. Other approach is to open Upfront editor, clicking Posts/Pages link, navigating to Pages tab and clicking "edit" icon of respective page there.

    #2) After entering in edit mode, find place where you want to render shortcode. Place there "Widget" element. Chose "Text Widget"

    #3) Enter Shortcode text in there, Save the page and view it.

    Hope this helps you. :slight_smile:
    Kind Regards,
    Milan

  • amy

    Hi Milan,

    I have executed that process many times with no success. I just did it again and left it on the page to show you. The shortcode is showing to the public and the widget is not displaying.

    On the plugin directions it says insert the shortcode into any post or page, so I was wondering if getting it into a blog post would work. However, I cannot seem to insert or edit a post in Upfront and the directions do not seem clear to me. Do I just create a post in the traditional way? What are all of the controls for a blog post in Upfront for then? The video instructions are not entirely clear.

    Thanks

    Amy

  • Adam Czajczyk

    Hello Amy!

    If nothing else helps, linking to the blog post where the working shortcode is located may be a "workaround". Most shortcodes however should work when put into the regular "Text" module of Upfront. The important part though is to put the shortcode there but not use any editing/formation options - just use a plain text shortcode.

    If you already tried that it may be helpful to remove such a "Text" module that has already been used and then:

    - go to "Upfront -> General" menu in admin dashboard
    - click on "RESET UPFRONT CACHE" button
    - and add a new Text box on page then put shortcode there and save layout

    Please note however that some shortcodes will only be rendered in a "non-Upfront" view (when Upfront editor is disabled) and also unfortunately there may be some cases where shortcode simply won't work and a workaround would be necessary.

    I'd however suggest giving it one more try the way I described above :slight_smile:

    Best regards,
    Adam