How do we configure for just 2 appts a day?

Our use is for a boating trip. Each boating trip lasts 2 hours and we take them at specific times: 10am and 1:30pm

We have set the folowing:
time base = 30 minutes
appointment length = 2 hours
working hours start at 10 and end at 3:30
break starts at 12 and ends at 1:30

However when we look at the calendar it shows
10:00 available
Noon not possible
2:00 not possible

We've also tried different working hours and break configurations, ending at 4 or no breaks
We can never get a 1:30 start time available

What are we doing wrong?

  • Adam Czajczyk

    Hey Val,

    I hope you're well today and thank you for your question!

    I've visited your dashboard and checked Appointments+ settings. There's a lot of sites though so I'm not sure which is the one in question. That said, I've checked the main one.

    I've noticed that although you've created some services, you didn't create service providers at

    "Appointments" -> "Settings" page -> "Service providers" page.

    You need at least one service provider, then on the "Working hours" tab you will want to select this service provider from the drop-down list and then set the proper working hours. So far, there's a break setup for "No specific provider" between 12 and 2pm for each working day and this affects all services.

    If this is not the issue, please point me to a right sub-site so I could take one more look.

    Cheers,
    Adam

  • Adam Czajczyk

    Hey Val,

    Thanks for information. I've checked this site and it seems like everything is setup fine. I've managed to replicate the issue on my own setup and I think I'll need some help here from our developers.

    I've found that the issue is most likely caused by how does the Appointments+ plugin calculate times. Assuming that your service is 2 hours long and a service provider works from 10am, the plugin creates time slot like this:

    1. 10am - 12am
    2. 12am -2pm
    3. 2pm - 4pm and so on.

    The break hours seem to be appended after this, not before. This results in booking for 1.30 pm unavailable.

    The "quick fix" here would be either to enable the "Allow Overwork (end of day)" options on "Appoitments" -> "Settings" page, however this will let your users book the event starting from 2pm.

    That being said, I've forwarded this message to our 2nd-line support team and hopefully they'll come up with a solution soon.

    Please keep an eye on this thread for further information and updates!

    Cheers,
    Adam

  • Adam Czajczyk

    Hey Val,

    Thanks for information. I've checked this site and it seems like everything is setup fine. I've managed to replicate the issue on my own setup and I think I'll need some help here from our developers.

    I've found that the issue is most likely caused by how does the Appointments+ plugin calculate times. Assuming that your service is 2 hours long and a service provider works from 10am, the plugin creates time slot like this:

    1. 10am - 12am
    2. 12am -2pm
    3. 2pm - 4pm and so on.

    The break hours seem to be appended after this, not before. This results in booking for 1.30 pm unavailable.

    The "quick fix" here would be either to enable the "Allow Overwork (end of day)" options on "Appoitments" -> "Settings" page, however this will let your users book the event starting from 2pm.

    That being said, I've forwarded this message to our 2nd-line support team and hopefully they'll come up with a solution soon.

    Please keep an eye on this thread for further information and updates!

    Cheers,
    Adam

  • Jose

    Hi there Val,

    Hope you are doing great today.

    You can achieve exactly what you need by activating the Durations add-on.
    It allows to change the timeslot calculus logic and us the legacy logic based on timebase instead of service duration.

    I'm attaching a few screenshots showing my settings and the resulting calendar.

    If for any reson you don't want to render the calendar showing the unavailable slots, you can add the following custom CSS:

    .app_timetable_cell.notpossible {
      	display: none;
      }

    Please let me know if this works as expected in your install.

    Cheers,
    José

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.