How do you change the name of a subscription plan?

I go to Membership > Subscription Plans click edit, change the title, press save but it reverts back to previous name again... It's driving me mad! :wink:

Any ideas where I'm going wrong?

S

  • Alexander
    • DEV MAN’s Mascot

    @sian_jones,

    I'm unable to reproduce this on my lab site. Can you create new plans? Or are you having other problems?

    I would recommend clearing your cache, and trying again, or try in another browser and see what happens.

    Let me know if this helps.

    Best regards, Alexander Rohmann

  • sian_jones
    • Flash Drive

    No, I can't :slight_frown: I get a "Subscription added" message in the yellow panel but nothing appears below.

    I'm also having difficulty while testing the registration process - the member gets created (appears in Users and I get a welcome email) but the only message I receive in the popup window is "You currently have a subscription for the [plan name] subscription. If you wish to sign up a different subscription then you can do so below."

    It should be redirecting to the registration page I've set up...

    help!

    SJ

  • sian_jones
    • Flash Drive

    Ok so repairing tables did the trick.

    But I'm still having this issue with registration.

    After the member fills in the first username/email/password form I just get a popup window empty apart from the message:
    "You currently have a subscription for the Exclusive members area subscription. If you wish to sign up a different subscription then you can do below."

    I only have one subscription plan, which is free.

    How can i either direct users to the Members landing page or give them a button to click to send them there?

    Is it the same issue as described here? https://premium.wpmudev.org/forums/topic/users-can-not-upgrade-their-subscriptions

    I'm struggling to follow these instructions however, possibly because they're for a previous version of Membership?

    S

  • Alexander
    • DEV MAN’s Mascot

    Hello again,

    I'll go ahead and mark this resolved as you were able to get the original problem sorted using "repair tables"

    I see you have another thread. I hope we're able to help you get all these issues forted out

    Best regards, Alexander Rohmann

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.