How do you edit css styles for the upfront theme in the database?

I have edited some css in the Upfront Editor and now the editor is non-functional. I don't want to reset all the regions to fix this as it would be too much work to start over. What I would like to know is where in the database is the css styles stored so that I can go in and edit the css in the database?

  • Sajid
    • DEV MAN’s Sidekick

    Hello David,
    Hope you are doing good today :slight_smile:

    The CSS and all other data is saved in options table of your WordPress site database. However, it is serialized, so it would be hard to find the relevant CSS rule and delete it without risk of breaking the site.

    So I would not recommend that.

    What error it gives you when you launch the Upfront editor ? Please enable support staff access so I could take a closer look and try to find any other way around.

    To grant access go to Dashboard -> WPMU DEV -> Support -> Support Access -> Grant Support Access or see this manual for more details regarding how to enable support staff access.

    Take care and look forward towards your response :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

  • David
    • Site Builder, Child of Zeus

    Ok, access has been granted. The issue is that I can't get to the CSS section in the editor. I set some z-index values to some regions and a widget. Now you can't click to edit the main body region. Nor can you get to the widget that is in the main region.

  • apurba_podder
    • Site Builder, Child of Zeus

    Hello David,
    Thanks for granted support access.Because of negative z-index you were unable to hover on button . I have commented your custom css. Now you will be able to edit the main area. Hope your problem has been solved.

    Kind regards
    Apurba

  • David
    • Site Builder, Child of Zeus

    Thank you for that. I wish I knew how you edited that css. There is another region right below the logo where the categories menu is located. I am unable to edit that region as well. Can you fix that for me please so I can edit that region. Also, did you make the edit in the database?
    Thanks!

  • apurba_podder
    • Site Builder, Child of Zeus

    Hello David,
    Thanks for reporting the issue.

    I have commented this custom css too. It's working now. Upfront give you the ability to add your custom css. So no need to edit css in the database . It is too dangerous.

    In custom css z-index value was 0. The element was bottom of another element . So you were unable to hover on the element . With the help Inspect tool I have fixed it. I would not recommend to use inspect tool for customizing you css. It will break your website. Rather than use Upfront editor to customize you css.

    Please contact us if you have any more issue. Take care :slight_smile:

    Kind regards
    Apurba

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.