How do you remove default SSL (https) from media URL?

My hosting plan does not support SSL, so whenever a non-logged in user goes to the website, all the images will show as corrupted.

At first, I was confused about why this was happening, so performed right-click --> open image in new tab. I was greeted with the message "This Site may not be the one you are looking for" (or something) and the "https" in url bar had "x" over it.

My site URL in Wordpress (general settings) is http://mydomain.com, so that's not where the problem is located. Also, I disabled SSL on Better WP Security plugin. I don't know what to do. I need help as soon as possible. All is appreciated.