how on earth to migrate site using snapshot pro?

i seem to be able to CREATE snapshots fine.

i can get them to dropbox, i can get them on the server locally.

every time i try to import a snapshot, however, i get an error that says "Error: Manifest data not found in archive."

again, i'm trying this with a fresh installation, following the instructions located here:
https://premium.wpmudev.org/blog/easy-migration-snapshot/

the page makes it sound easy up until it joyfully says:
A “success” message should be displayed at the bottom of the page.

okay, well what do i do if a "success" message is NOT displayed?

i should also point out that the error comes up instantly. there is no way it's downloading and processing a 125MB file in the time it takes to display the message.

also, when it restates the filename for me just above the error it says something in parenthesis like (204.41 KB) which i assume means that's how big it thinks the file is?

i have tried using dropbox, i have tried using another web server directly from URL.

i really wish there was a way to UPLOAD but i don't see that functionality anywhere, maybe i missed it.

i tried using WinSCP to upload but i got a permissions error.

is it possible that the install of snapshot pro doesn't set (or check) the permissions properly?

this is happening on both installations i have. same exact problem. two completely different systems.

one is a fresh install, the other is the "source" install.