How practical is it to create a blog using Pro Sites ?

When people try to create a blog on my website, they get to the Congratulation Page where the are told that their blog "their_username.MYWEBSITE.com" is almost ready and that they shoudl check their email to activate it.
When they try to either click on their_username.MYWEBSITE.com on the Congratulation page or activate their new site from the email sent to them, they get a blank page with PAGEOK written at the top left corner.
What is worse, is that I " the admin" get no notification whatsoever that someone is trying to create a blog through my website !!!! hmmm why is that ?
It is only possible to create a new blog if, AND ONLY IF, the USERNAME is has already been added as a subdomain by me in my website hosting. How could that be practical?
I can not understand why it is setup like this if it is the case ???
I thought this should work like this:
Someone will go to my site, enter their info, click GIMME A SITE and BAM, they get their wordpress site ! which would look like this their_username.MYWEBSITE.com and which I would have to go and clone it to look like my site later.
Am I wrong? Am I missing something here? is their another way fo doing this?
Thank you

  • Tyler Postle

    Hey Rachid,

    Hope you're doing well today! Thanks for the question.

    I thought this should work like this:
    Someone will go to my site, enter their info, click GIMME A SITE and BAM, they get their wordpress site ! which would look like this their_username.MYWEBSITE.com

    This is exactly how it should work.

    It sounds like your wildcard subdomain might not be set up properly. You shouldn't need to setup a subdomain manually.

    Have you setup the wildcard subdomain at all yet? Make sure the document root is pointed to the root of your installation. Usually /public_html/ I'll attach a screenshot to illustrate :slight_smile:

    which I would have to go and clone it to look like my site later.

    If you use our New Blog Templates plugin, then you don't have to clone anything. It will do the "cloning" automatically on sign up so the site looks exactly like the template site that you setup :slight_smile: easily one of my favourite plugins! Can save a ton of time.

    It should be sending you the email notification of a new site too. The site creation and emails being sent out is actually handled by default Multisite. Pro Sites doesn't really come into play until after the site is already setup.

    Let us know if you have the wildcard subdomain setup and if it's still not working then we can troubleshoot this further with you :slight_smile:

    Cheers,
    Tyler