How to add audio files to page in Upfront...?

Hello,

I want to add an audio file to a page in Scribe/Upfront. I do not see a drag/drop for this in customization.
If I go to the backend (?)- "Edit" where I used to build pages pre-Upfront there is the "add media" button. This worked fine in the past.
Maybe it still works fine but Upfront has scared the bejeezus out of me with the various warnings about the domino effect of changing things.

I'm not super smart or super computer smart so I do not know what constitutes the kind of change Upfront wont like.
I think changing fonts, colors is changing formatting and will upset Upfront.
Is adding media also changing formatting? Should I continue to use the "add media" button
from the "edit" backend page?

Thanks for your help,
Peter

  • Michael Bissett

    Hey Peter,

    I want to add an audio file to a page in Scribe/Upfront. I do not see a drag/drop for this in customization.

    Right now, there isn't an official "Audio" element yet, but if you were to take the shortcode generated in the backend, which usually looks like this:

    [playlist ids="1263"]

    (of course, with the appropriate ID)

    And then insert that shortcode into a text element, that's one way you can insert it via Upfront, and have it displayed on the front end.

    Now, the shortcode will not execute while inside the editor, just so you're aware, but you can change the width of the text element via our padding controls. I'd hinted on the vertical ones in a prior post of yours, but inside of the element settings, inside the "Advanced Settings" section, there's a "Customize Padding" box there that you can check, and adjust the values there to suit your needs.

    Kind Regards,
    Michael

  • peter

    Hi @Jude,

    You got the short straw with me today and you are bing very patient.

    Thank you for your offer, but I will be adding lots of audio files, and I want to be able to know htat I can do it myself.
    I have seen instructions regarding inserting code-- but I am a huge code chicken-- even wpmudev WARNING msgs scare the hell out of me so.....

    I'm still hoping the answer is yes..... Can I use the old "add media" button- photo in previous msg.
    I know how to use that, I'm just not convinced Upfront is ok with it.

    Cheers,
    Peter

  • peter

    I have successfully placed audio files via shortcode [playlist ids="1263"].

    Finding the "1234"- meant going to the media library, opening the particular file and then looking up in the URL.

    When I put the shortcode in a text box- the annoying publish draft thing popped down- and after saving- in customize mode the shortcode was invisible.
    Doing the same in a Tabs box- the shortcode remained visible.

    Looking at the site as a normal person- the files were there and its all good.
    But for people like me- putting the code in and then not seeing it-- stressful.

    Next issues- maybe resolved with an audio tab is the appearance of the audio file- in non-upfront theme it was just the play bar- in upfront I have a lot of text etc (photo). I like just the playbar.

    SIDE NOTE:
    I also put audio in through the non-upfront Edit page "add media" button (photo bak up 2 or 3 msgs)-
    this worked fine for two posts and not at all for a third. No idea why.

    Interestingly, looking at the pages in Upfront/customize the audio files were invisible.
    Looking at the page in backend Edit only text from one text box was visible- the rest of the page.....?

    Thanks again for all your help,
    Peter

  • Michael Bissett

    Hey @missybon,

    Can I use the old "add media" button- photo in previous msg.

    This only shows up in the backend post editor.

    Finding the "1234"- meant going to the media library, opening the particular file and then looking up in the URL.

    I'm not sure I understand this one, but I should've explained further earlier. The way I did it was to first go through the process to insert the audio in a dummy post (i.e. one I didn't plan to actually display on the front end), and then copy the inserted shortcode into a Text element inside of the intended post.

    When I put the shortcode in a text box- the annoying publish draft thing popped down- and after saving- in customize mode the shortcode was invisible.

    Doing the same in a Tabs box- the shortcode remained visible.

    By "text box", you're referring to a Text element placed onto the page:

    http://screencast.com/t/xH4K93DUI

    Is that correct? I can't say I've run into that behavior before, that's why I'm making sure.

    Next issues- maybe resolved with an audio tab is the appearance of the audio file- in non-upfront theme it was just the play bar- in upfront I have a lot of text etc (photo). I like just the playbar.

    Part of this requires the setting of other shortcode options, like these:

    [playlist images="false" tracklist="false" tracknumbers="false" artists="false" ids="1263"]

    But even with all of those used, there's still the title being displayed by WordPress, which seems to be the out of the box behavior for WordPress (without an option to turn it off).

    That said, this can be resolved with a bit of CSS code, inserted into a preset:

    .wp-playlist-current-item {
        display: none;
    }
    
    .wp-playlist.wp-audio-playlist.wp-playlist-light {
        padding: 0;
    }

    Kind Regards,
    Michael

    P.S. I noticed this was marked as resolved, I marked as un-resolved since you had these open questions. Unless they were sorted out otherwise already?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.