How to allow PHP in widget? Does Exec-PHP plugin work on WPMU?

I'm not worried about security, but I need to allow php code to execute in a widget. What's the best way?

I really only need that support in widgets, but I don't care if the solution also works in posts and pages.

The developer of Exec-PHP plugin doesn't seem to know if it works with MPMU. Anyone here using that? If so, does it go into the mu-plugins directory?