How to allow two services to be booked in the same time spot

Hi, I have one service provider and two services. The circumstances are a little different in that I can have both services booked at the same time slot which I currently can't do with the plugin since when one service gets booked, the spot isn't available anymore for the second service to be booked. Any suggestions?

    pxwm

    Hi,

    The should be achievable by setting up a 'Dummy' service provider

    Try the following:-

    1. Setup a 'real' service provider and set the working hours as required.
    2. Then setup a 'dummy' service provider with the same working hours as the 'real' service provider assuming you want to offer the full set of working hours as per the 'real' service provider. Remember to select the 'dummy' checkbox.
    3. Then set the 'work' field to 'No' for the 'no specific provider in the 'Working hours' tab. This will disable the appointment calendar so appointments can only be made by selecting the real' service provider.
    4. Then in the 'General' tab set the 'Assign Dummy service providers to' dropdown field to the 'real service provider'. This should send emails to the 'real service provider'.
    5. Creating one dummy service provider will allow you to book the same time slot twice. Two dummy service providers will allow you to book the same time slot three times and so on.

    It does mean that to make an appointment you will need to select the 'real' service provider in the appointment calendar.

    You may also wish to check out the FAQ tab in the plug-in admin panel and search for 'dummy'

    Please let me know if this works for you.

    Regards
    SteveB

    ctaillon

    Hi Joe and Steve,

    Thanks for your quick responses! Steve - I think your idea will work. The problem I'm running into with Service Providers is that even when I set them up, they don't appear. The only Service Provider showing up on the page is the Wordpress username I'm logged in with. I have two setup not including the username I'm logged in with, but when I view the page, the only option is my own, not the two I've created. Any thoughts?

    Caitlin

    pxwm

    Hi,

    Could you confirm how you have created the service providers?

    The reason I ask is because you have to create a user profile in the main Wordpress admin panel and give them an Editor profile.

    To confirm you only have to do this for the 'real' service provider.

    For the dummy service provider you just create a profile in the A+ service provider tab.

    Once you have created a Wordpress user profile with Editor access you then need to go into the A+ settings page and select the service provider tab and create a service provider for the 'real' service provider and the dummy service provider making sure you click the checkbox indicating they are a dummy.

    You then need to go into the 'general' tab and assign the dummy to the 'real' service provider.

    This should then show the 'real' service provider but NOT the dummy when you select a service and make an appointment.

    Hope this helps

    Regards
    SteveB

    ctaillon

    Thanks Steve - you had it right. The issue was how I created the service providers. Under the user settings, the "display name publicly" dropdown by default selects the user you are logged in with. I switched that and it fixed the problem. Now I can use your idea with setting up the Dummy service provider to achieve what I need to set up.

    Thanks for all your help.

    Caitlin

    pxwm

    Hi @Mattbkelly

    I've read my original post dated Apr 2013 and subsequent posts and I'm not sure if the code in future versions has changed but I can confirm that if you create a 'real' Service Provider and then 'dummy' Service providers as I suggested then you have to create a Wordpress user profile for each Service Provider whether 'real' or 'dummy'.
    Then in A+ you assign a 'real' Service Provider in the 'General' tab and then in the 'Service Providers' tab you tick the relevant 'dummy' checkbox.
    You then need to set the Working Hours accordingly for each Service Provider 'real' and 'dummy' and the assign the 'Services' accordingly.

    However I've just tested this and I can confirm that the 'real' and 'dummy' Service Providers will be visible in the dropdown when you are making an appointment.

    The only option I can suggest which could resolve this is as per my suggestion in the following post: https://premium.wpmudev.org/forums/topic/services-without-service-providers

    This way you can 'control/hide' the 'Service Provider' by the user having to click a button that will automatically select the 'Service' and 'Service Provider' and it will then navigate to the Appointment page and show the calendar schedule to book a time slot.

    I would suggest if you opted for this solution you could then 'hide' the 'Service' and 'Service Provider' dropdowns on the Appointment page.

    I hope thi shelps
    Regards
    SteveB