How to clone a site?how to clone a site?

Hello Admin,

How to clone a site?

I have a site under my super admin panel http://www.blog.prosper8dotcom.com/home
and i wanted to clone or copy the same site as is to another user site's of mine, how can i do that?

I make a question because i have tried to copied my site to another but the result is very different not what i thought to be the same site or template.

That's why i got confused.

Please help.
Thanks a lot.

  • Tyler Postle
    • CGO

    Hey David,

    Hope you're doing well today!

    Cloner should be cloning everything as is. What wasn't displaying properly after cloning? Or let me know which subsite you tried to clone it too then I can take a look :slight_smile:

    Have you tried cloning it to a brand new url? Did it clone properly then? You will also want to try with just the default 2015 theme. It could be a theme conflict and if so then we can look further into it.

    Look forward to hearing back!

    All the best,
    Tyler

  • David
    • The Incredible Code Injector

    Hello,

    This is the exact site that i really want to clone that i already did. : http://blog.prosper8dotcom.com/home/ ; http://blog.prosper8dotcom.com/

    That's the template and this is originally located at my own super admin panel.

    All i wanted is to have a the same and exact template to another user's site.
    I am currently using particularly the elegant themes and it works fine in many aspects but after cloning this site - http://blog.prosper8dotcom.com/home/ from my super admin panel,

    then the result was not the same.... the result was a default template of divi elegant theme which is not supposedto be because as i have understand CLONER PLUGIN is simply for copying, for cloning.

    Hope anyone can help me to resolve this issue.

    Many thanks.

  • Anang
    • New Recruit

    Hi David

    Working with Tyler here :slight_smile: I tried on my installation working fine, I cloned website perfectly all themes all set including the content. Could I try it on your site ? So I can see what's wrong with cloner on your site, maybe some error will popup when cloning in progress.

    Let me know if I can try on your site :slight_smile:

    Best Regards

  • David
    • The Incredible Code Injector

    Hello Anang,

    Thanks you're really the best help for me especially with those crucial point like before.

    I really appreciate your best kind support.

    you are really awesome, hope if i can ask also for a more support from you, it's okey for me to pay extra charge in order for me to launch my site in public.

    I cannot launch because i am afraid of many things, still not yet done, because lack of my technical knowledge.

    Hope you can help me because i am afrais to ask for a help to others outside from WPMU DEV.

    Hop you may help for me to establish every point at my site.

    I used to pay the subscription since February 2015 this year and still up to now i cannot use it for my public users because of many times i encounter errors.

    Thank you very much once again hoping for your kind consideration to support with me and please let me know.

    Yes you may do whatever you want inside my admin and also to my some users, please you may. Grant Access is already open.

    Thanks a lot.

  • Anang
    • New Recruit

    Hi David

    Thanks for your compliment :slight_smile: I'm trying my best to help you here :slight_smile:

    I have tried to cloned site on your isntallation, and I can confirm I get blank white page when I try to access it. Here's the steps that I did :
    1. Clone from main site
    2. Grant pro level so I can access the site
    3. Got blank white page.

    Could you enable Wordpress Debug, so I can find out where to find the errors ?
    https://codex.wordpress.org/WP_DEBUG

    Let me know if you have enable WP_DEBUG :slight_smile:

    Best Regards

  • Anang
    • New Recruit

    Hi @David

    It seems we have plugins conflict here, and I see you have tons of plugins that installed on your website. Could you send me your server error logs so we don't need to check all plugins one by one ?
    It usually on your control panel menu or contact your hosting provider to give it to you :slight_smile:

    Looking forward for your error logs :slight_smile:

    Best Regards

  • Anang
    • New Recruit

    Hi David

    You could send it here :
    https://premium.wpmudev.org/contact/
    Subject: "Attn: Anang"
    -FTP credentials (host/username/password)
    -CPANEL credentials (login url/username/password)
    -link back to this thread for reference
    -any other relevant urls
    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :simple_smile:

    Looking forward for your info :slight_smile:

    Best Regards

  • Anang
    • New Recruit

    Hi David

    I have check on your cpanel that php error logs is not turned on by default, so I can't find the logs.I think we need to do manually with plugins conflict check. Can I disable all your plugins to check conflicting plugins ?

    Let me know if I can go with plugins check on your site :slight_smile:

    Best Regards

  • David
    • The Incredible Code Injector

    Hello Anang,

    Would you mind to edit that error logs to turn on?
    As far as i know i already turned it on, but maybe i was misconception, i don't know really, since i am not a technical person really.

    You can do anything you want as long everything will be alright. Please.

    Thank you very much for giving importance to this issues.
    More power.

  • Anang
    • New Recruit

    Hi David

    I have turned on the Debug, you do right but do it on the wrong path :slight_smile: I enabled the debug on blog folder. Now it's give me a clue for the errors. I will attached log file here :

    Could you check that files and tell me if some plugins mentioned there is required or not for your site . Meanwhile I will going to test plugins conflict check based on that error logs.

    And will let you know the result :slight_smile:

    Best Regards

  • Anang
    • New Recruit

    Hi David

    I have turned on the Debug, you do right but do it on the wrong path :slight_smile: I enabled the debug on blog folder. Now it's give me a clue for the errors. I will attached log file here :

    Could you check that files and tell me if some plugins mentioned there is required or not for your site . Meanwhile I will going to test plugins conflict check based on that error logs.

    And will let you know the result :slight_smile:

    Best Regards

  • David
    • The Incredible Code Injector

    Hello Anang,

    Thanks for your personal support to this issue.
    If there's a plugin conflict, well, no choice it's better to deactivate.

    But i think it's really base on your professional advises. And i am very confident regarding your capacity to this matter.

    Thank you so much for this wonderful support.

  • Anang
    • New Recruit

    Hi David

    Good news , I found the culprit :slight_smile: From the error logs I can analyzed that you're not setup your newsletter plugin so the Cloner can't find the related tables :slight_smile: (but I don't think this is critical) , and the critical one is you must check "settings" options in Cloner settings , so your default themes, permission and others required settings got copied and adjusted to the new site :slight_smile:

    I also attached where to find Cloner settings. And I have activated your plugins (no plugin conflict after I check) , and delete my cloned test sites.

    Please check to clone the main site by yourself ,and let me know if you need any help :slight_smile:

    Best Regards

  • David
    • The Incredible Code Injector

    Hello Anang,

    Thanks a lot for giving a solution,.

    But i still have a concern regarding the menus originally on the "knowledge" admin site user ...
    The original menus only on the left side is only few menus only.

    But after cloning the original site template from super admin panel, the result also copied exactly the same with the menus on the super admin panel.

    Which is not my intention.

    Only my intention is to copy is the site template only, not to the point even the menus inside my super admin panel.

    And also how can i make my template becomes the BLOG TEMPLATES of any new registrant user?
    I mean exactly the same site template that they can edit thru their user admin panel?
    That is really my main purpose why i use the CLONER for a SITE TEMPLATE in the BLOG TEMPLATES in order for upcoming users can simply click the template and already made BY ME... AS IN THE SAME WITH MY SITE TEMPLATES FOR THEM TO USE ASAP, AND MAKE SOME SMALL EDIT ONLY.

    Thanks once again. Please advise. Thanks a lot.

  • Anang
    • New Recruit

    Hi David

    Ah so from your requirement above all you need is using New Blog Templates plugin here :
    https://premium.wpmudev.org/project/new-blog-template/

    It will allow instant creation of website when user register on your site. And you can create many templates based on your existing multisite website. So you need to setup "a template" website that consist all setting you want , plugins that allowed to access, default themes, etc

    Also I check your installation already installed new blog templates :slight_smile: You can read our guide on plugins usage on above link or watch or youtube tutorial here :
    https://www.youtube.com/watch?v=88P1AQUcuaE

    Let me know if you have any questions :slight_smile:

    Best Regards

  • David
    • The Incredible Code Injector

    I tried your instruction very well.
    But i made a screenshot because this message shows " You must select at least 0 unique categories"

    since i don't see any option to choose. And i have also tried to configure different aspects in the BLOG TEMPLATES plugin.

    Please advise. Thanks a lot. Looking forward.

  • Anang
    • New Recruit

    Hi David

    I check you have "Site Categories" plugin installed, I have deactivated it for now so you won't prompted with "Site Categories" field again when user Signing Up to your site :slight_smile: Feel free to reactivate this plugins again when you already have Site Categories entries for your site :slight_smile:

    Best Regards

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.