how to disable https on my multisite

Hello,

I have installed ssl certificate on my multisite. But now, all my sub-sites are not aviable. So i need to know please :

1. How to completly remove the https, i mean turn ssl off

Cheers

  • Kasia Swiderska
    • Support nomad

    Hello liensenor,

    Your subsites are not working because your ssl certificate is not wildcard certificate, so it will work for only main site not subdomain.

    If you want to switch again to http you will need to revert changes you made to switch to https. You didn't provide any details how did you done that so Im not sure if you used plugin or made those changes in database.

    If by plugin, then remove plugin. If by changes in database then you will need to edit three fields in it. Log to your database using PhpMyAdmin (if you have access to cPanel there should be link there). Find tables wp_options (wp is prefix, it might be different in your database) – its important that table has no numbers in name. There find fields siteurl and home – you will see that those contains your site url with https – edit those to be http.

    this is how it looks on my local phpmyadmin

    Then find table wp_sitemeta (again, wp prefix can be diffetent) and there find siteurl meta_key – also change it so it wont have https anymore.

    That should get back your mulitsite to http.

    if you added any redirects in your htaccess file, also remove them.

    Let me know how it goes.

    kind regards,

    Kasia

  • Nithin
    • Support Wizard

    Hi liensenor,

    Hope you are doing good today. :slight_smile:

    I checked your website, and I was able to notice that your site URL, and Home URL both loads http, so it does look fine. However, in Domain mapping website you did force your website to load in HTTPS, hence your multisite was loading in https protocol. I have disabled https in the Domain mapping settings, as shown in the screenshot below:

    Also, check whether you have defined the following code in your wp-config.php file, located in your root directory:

    define('FORCE_SSL_ADMIN', true);

    If yes, please remove the above code form your wp-config.php file, and this should make your admin load fine in http, would recommend you to clear the browser cache, and check whether it works fine.

    Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,

    Nithin

  • Rupok
    • Support Ninja

    Hi Mohit,

    I’m so sorry to hear the inconvenience you are having. Can you please ping us through live support chat so we can investigate your issue and try to find out what’s happening on your site/server and try to resolve this issue?

    I’m looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!

    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.