How to Disable "no preference" service provider

In the booking form it gives an option to select "no preference" as a service provider. how can i disable this so it only shows the service providers that are listed?