How to downloads and media files protection?

Hi All,

can you please somebody write me step by step how can I set the downloads and media files protection?

I use the latest Membership plugin 3.0 and cannot find the solution.

I do this:

Create 3 Access Levels:

– Strangler – read the all default post, but cannot read and write comments

– Default membership – free subsription: read the all default post, To be able to read and write comments and can download defalut media

– Premium – this is inactive now

In the Options menu I set the Default membership to the Protected groups in Download / Media Options. And I set Masked download URL: http://wordpresskezdoknek.hu/premiumletoltes.

I edited the Default membership level int the Access Levels. And I add the comments and the downloads widget to the positive rule.

I edit the downloadable media in the media manager and set the default membership.

I insert the downloadable file to a post this method: http://wordpresskezdoknek.hu/premiumletoltes/Membership-Docs1.pdf

But the user who is the member of the default membership cant download the file.

Please help. What should I do?

Thanks,

Robert

  • Timothy
    • Chief Pigeon

    Hey whi.

    Just taking a look at this one for you.

    First can I check, did you read the manual about this? If not there is a full manual available direct from our docs page or from this post:

    https://premium.wpmudev.org/forums/topic/membership-30

    I’m going to break your post down, as I’m not sure I completely understand, so I appreciate your patience whilst I help you with this one.. :slight_smile:

    Create 3 Access Levels:

    – Strangler – read the all default post, but cannot read and write comments

    If you want the Strangler level to not have access to those things then you need to set negative rules.

    So choose Negative and add Comments.

    Then also add the downloads, anything checked will be negative i.e. not accessible. Anything not checked will be viewable by that level.

    Does this make sense now?

    – Default membership – free subsription: read the all default post, To be able to read and write comments and can download defalut media

    So you don’t need to add posts as a positive rule, because by default everything on a level can be seen if you set your Strangler level within the options admin (Please see page 9 Of 6 of the manual for more details). If you don’t have the stranger level set, then its all protected by default unless a Level dictates otherwise.

    Please feel free to ask for clarification if your not quite following. :slight_smile:

    Each level is independent from the other.

    I edit the downloadable media in the media manager and set the default membership.

    I insert the downloadable file to a post this method: http://wordpresskezdoknek.hu/premiumletoltes/Membership-Docs1.pdf

    Ya, I don’t see that because I’m not on the Level :slight_smile: See screen.

    So the question is, is the stranger level set correctly?

    Does the member have the right level set on this account?

    If all that checks out and its right, would you mind me taking a closer look?

    Let me know.

    Take care.

  • whi
    • Design Lord, Child of Thor

    Hi Timothy,

    thank you very much for your detailed answer!

    I wouldn’t mind you taking a closer look… :slight_smile: I think my settings are correct – according to your list as well.

    Is that all right if you subscibe on my page, and than I give you admin rights? Or how did you think?

    When trying ot download that masked url on level strangler it drops an access denied error message, but if a member tries to download the error message is 404…

    May be I’m wrong with the link of the masked url.

    The default WordPress download link looks like this: http://wordpresskezdoknek.hu/wp-content/uploads/2012/03/Membership-Docs1.pdf

    and I’ve changed it like this (with mask url): http://wordpresskezdoknek.hu/premiumletoltes/Membership-Docs1.pdf

    Is that correct or does this cause the problems?

    Thanks a lot!

    Robert

    edit: I use this custom permalink structure: /%category%/%postname%.html

  • Barry
    • DEV MAN’s Mascot

    Hi, when you say that you’ve changed the default wordpress download link, can you let me know where you have changed it? If you mean that you have changed something outside of the membership options then that is indeed wrong. You should be using your standard wordpress download / upload link and should be inserting that into your posts (using the standard Insert into post button) the membership plugin will then take care of switching the url to the protercted one, and serving the content when that url is requested by a user.

  • whi
    • Design Lord, Child of Thor

    Hi Berry,

    I sent the login details to the Tim throught contact form. Tim check the settings and he found everything is ok. So I don’t understand what is the problem…

    I use the default wordpress download link.

    Thanks for the help.

    Robert

  • Barry
    • DEV MAN’s Mascot

    Hi, I based my response on what you wrote originally and in reponse to tims questions, and twice you mentioned that a) you changed the default download location – so I just need to find out which one and were, and b) that you were putting the masked url in to your posts rather than the standard wp one – so need to check that you are not doing that.

    Can you let me know when / if it’s convenient for me to have a look at your system? Did you send any ftp details through to tim? May not need them, but it would be handy to help with debugging.

    I know tim logged in and did a check, but the fact that it isn’t working suggests that something is set wrong or something more complex is going on that we haven’t discovered before.

  • Barry
    • DEV MAN’s Mascot

    Hi, was on your site earlier today, I’m going to code up some little addons for debugging and will upload them and see what else I can find about why this isn’t working for you.

    Will let you know as soon as I’ve tracked it down.

  • aecnu
    • WP Unicorn

    Greetings whi,

    Just touching base with you to let you know that we have not forgotten about you nor your issue.

    Hopefully our extremely busy developer Barry will have the chance to make it back in here sometime soon to continue on possible resolution of your issues.

    Cheers, Joe

  • Barry
    • DEV MAN’s Mascot

    Hi @whi – we uploaded an update of the membership plugin today, it has quite a few fixes in there, but more importantly for your issue it has an extra bit of information and the ability for us to override the plugins default setting and hopefully get you back up and running again.

    Can you grab it and install, and see, initially, if it helps straight away. If not, then shout on here and we can take a look at what it thinks your settings are and see if we can force it to use the correct ones.

  • Barry
    • DEV MAN’s Mascot

    Is that in the new area on the downloads options page? Can you pop up a screenshot of that bit of the page for me? If that is there, then no that isn’t correct so we can then see if adding the new override in will help :slight_smile:

  • whi
    • Design Lord, Child of Thor

    For the first sight it seems to work all right now! Thank you very much, it was worth to wait… :slight_smile:

    I’m still testing it but hopefuly there won’t be any issues.

    May I ask you what was the problem (solution)? Did you have to modify something in the code of the Membership or was it something else?

    Thank you again for your help! :slight_smile:

    Robert

  • whi
    • Design Lord, Child of Thor

    HI Berry,

    Unfortunatly it is still not perfect…

    Someone wrote that pictures disappeared from his site, and I’ve checked and it seems the same: I can see the pictures as admin, but as a stranger not.

    The protected url can be seen on the status bar at the images, but there is no protection set anyway..

    Can you, please, help us with this problem?

    Thank you!

    Robert

  • whi
    • Design Lord, Child of Thor

    Hi Berry,

    I realized that all the image’s link which were uploaded before the installation of Membership plugin were broken. The ones I’ve uploaded after the installation works all right.

    Now I solved the problem with uploading the wrong images again, and they works all right now.

    So I think it has something to do with the installation of this plugin, something happens that times…

    Best regards!

    Robert

  • locomo
    • The Incredible Code Injector

    @Barry – is there a timeframe for when this fix will be rolled out in a new release?

    I believe i’m following the instructions correctly in this thread

    upload location is the standard: wp-content/uploads

    masked download URL is: downloads

    i have created a “protected group” and added it to the appropriate access level

    in a post i used this protected group for a PDF file upload and inserted it into my post with normal file URL: wp-content/uploads/my-file.pdf

    when i click on the link as a user with this access level i see a “no access” graphic .. when i open the actual url of the pdf it downloads

    please advise!

  • aecnu
    • WP Unicorn

    Greetings,

    It appears this particular topic is now resolved/closed, if you need any further assistance please let us know.

    If it wasn’t resolved, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the ‘Mark as Not Resolved (re-open)’ box below the post area (or else we’ll miss it!)

    Thank you for being a WPMU Dev member!

    Cheers, Joe :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.