how to enable browser caching and activate minification

the website is extremely slow according to Google PageSpeed Insights so I decided to install hummingbird. Hummingbird does not allow me to enable browser caching, when I click on yellow button "disabled" it does not do anything.
When I click on activate minification, it scans and remains 0%.
Please advise.

  • Nahid

    Hi Sam !
    Hope you are having a great day!

    Well, this seems to be a very unusual issue and I've two suggestions for troubleshooting the issue:

    1. Debug Log:
    To get more info on the issue, can you enable WP_DEBUG in your wp-config.php file and tell me if there are any errors displayed?

    To output the WordPress debugging information you can open your wp-config.php file and change:

    define('WP_DEBUG', false);


    define('WP_DEBUG', true);

    You can also have these errors output to a debug.log file located in your /wp-content/ folder, to do this add the following to your wp-config.php file:

    define('WP_DEBUG_LOG', true);

    Using WP_DEBUG would put the errors on the site, you can hide those and just have them out put the WP_DEBUG_LOG (if set to true) by using this as well:

    define('WP_DEBUG_DISPLAY', false);

    After the process of adding these to your wp-config.php and initiating an analysis again, you'll find the debug.log file in your wp-content directory. Just attach the file to your next reply for me.

    2. Plugin/Theme Conflict Test : Can you try a plugin/theme conflict test to check if any other plugin/theme is conflicting with Hummingbird. You can simply deactivate all other plugins but Hummingbird and WPMU Dashboard and reverting to a default WordPress theme like Twenty Sixteen and then initiate an Analysis again.

    I'll be looking forward to hearing form you. Thanks!


  • Nahid

    Hi again Sam !

    I diagnosed your site and the issue is most likely caused by the 'WishList Member' plugin. If you deactivate the plugin, you'll be able to see a screen like the following:

    Due to activation of the 'WishList Member' plugin, the status of the Hummingbird Browser Cache and Minification dissapears. But it seems they are running. We are still trying to replicate the issue on our side and if we can confirm its a bug, we'll definitely fix it in the future update. For now, to make the Browser Caching and minification work, follow the instructions below:

    1. Deactivate the 'WishList Member' plugin (Just for now).
    2. Navigate to Hummingbird > Browser Caching. It'll say its running properly but you need to add some code to your .htacces file. All instructions are provided there (Like in the screenshot above).
    Let me know if the status for Javascript, CSS, Media and Images still show as disabled after you have added the code to your .htaccess file and restarted Apache (Please ask your host to help if you can't find the file).
    3. Try running Minification too in Hummingbird > Minification.
    4. After all your processes are complete, reactivate 'Wishlist Member'. Browser Caching of Hummingbird will be running in the background no problem if it doesn't even show up in Hummingbird > Browser Caching (Though status of Javascript, CSS, Media and Images will show enabled).

    Hope this helps. Let me know if you need any further assistance regarding this. Thanks!