How to enable minify for admins but default set to off

Hi there,

I need a good minify solution for my multisite that allows subsite's admin to setup their own. Now Hummingbird does have this perfect solution, but unfortunately it breaks the layout 90% of the time. It needs tweaking and not every one can do this so easily.

So how can I enable this option for site admins but it's disabled until the site admin decides to turn it on and tweak it.

Cheers,
Ronald

    Predrag Dubajic

    Hey Ronald,

    Hope you're doing well today

    Minification can be a bit tricky tool and in some cases indeed requires tweaking to get it working properly with theme/plugin combo you have on your sites.

    When you go to Hummingbird > Dashboard panel in your WP Network admin section you can actually select who can use minification on your network.
    This way you can enable minification for Super-Admin only and your subsites admins won't be able to enable minification and only Super-Admin can enable and adjust it.

    Let us know if that's what you're looking for

    Best regards,
    Predrag

    Adam Czajczyk

    Hello Ronald!

    If you select the "Blog Admins can minify" option from the drop-down list in "Minification" section on "Network Admin -> Hummingbird -> Dashboard" page, admins of sub-site will be able to minify but not forced to.

    The "minification" is not enabled by default, the option will only show the "Hummingbird" option in sub-sites' dashboards. Then, an admin of a sub-site (or a super-admin) can enable minification by clicking on "Check Files" button there. Only after that minification is enabled and then can be "fine tuned".

    The only exception is this:
    - the minifcation has been enabled on the sub-site
    - then, without disabling it on the sub-site, it has been disabled in Network Admin
    - and then it's been enabled back in Network Admin

    In such case, it will be automatically enabled on sub-site but in any other case - if it was never used on a sub-site before or it was left disabled there - it shouldn't be automatically enabled.

    Kind regard,
    Adam