How to enable NGINX Gzip compression...again

A couple of weeks back, while working on and tweaking my sites to resolve some (still unresolved) issues, I turned off the NGINX compression option in Hummingbird > Gzip Compression

I had assumed that like everything else, I'd have the option of turning it back on. Apparently I can't.

Now all of my sites have this feature turned off.
I have a notice saying:
----
Enable compression
Follow the instructions to activate GZip compression for this website.
For NGINX servers:

Copy the generated code into your nginx.conf usually located at /etc/nginx/nginx.conf or /usr/local/nginx/conf/nginx.conf
Add the code above to the http or inside server section in the file.
Reload NGINX.
If you do not have access to your NGINX config files you will need to contact your hosting provider to make these changes.
---

You can see more information here https://i.imgur.com/3lMWh7t.jpg

I'm not sure what to do - thanks!!

  • Kasia Swiderska
    • Support nomad

    Hello DigitalMu ,

    If you are checking sites that are hosted on WPMU DEV Hosting they have enabled Gzip. You can check that here: https://www.giftofspeed.com/gzip-test/
    This is configured on the server and only way to turn it off is to change the config file. But since it shows in the gzip checker that it is enabled, then it is still turned on.
    Are you sure it's disabled in Hummingbird? Would you mind allowing support access so we can have a closer look at this? To enable support access you can follow this guide here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    Please respond in this ticket once access is granted.

    kind regards,
    Kasia

  • DigitalMu
    • Design Lord, Child of Thor

    Hiya Kasai,
    Inside Hummingbird, there *was* an option to turn off the Gzip Compression. Thinking that I could simply turn it on again, I hit the button to turn it off. It was weird.

    Per your request, i just activated support access. thanks!!

  • Rupok
    • Support Ninja

    Hi DigitalMu,

    So sorry to hear the inconvenience you are having. I clicked on the "RE-CHECK STATUS" button and now all are green. I'll suggest you do so in all your sites hosted with our hosting. That should resolve the issue.

    Please let us know if you have any confusion or any further query or if this doesn't work on any of your sites hosted with us. We will be very glad to assist further.

    Regards,
    Rupok

  • DigitalMu
    • Design Lord, Child of Thor

    It seems to be working now (at least the lights are green, as you mention). Still, I'm pretty sure I selected an option to turn it off....and if you look at the graphic in the top, it suggests that some code needs to be added somewhere. If I remember correctly, that information was not presented to me until I accidentally turned it off. HTML was red for awhile but yeah, it's green now.....but I'm still being told that I need to add that code to enable. So I dunno/ Thanks!!!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.