How to enable WWW in all my site

Dear Members,

I realise in wordpress MU, all sites are non-www.

I will like to make the option for my member the option for www, how can I get it done?

Jack

  • PC
    • WPMU DEV Initiate

    Heya Jack,

    what I understand is that the websites in your network are being created without a www. Right ?

    Please advise

    Though www. does not impact accessibility of sites, they are accessible with or without www.

    Regards,
    PC

  • PC
    • WPMU DEV Initiate

    I am just waiting for Joe, for his expert advise on it.

    @Joe, I also have the same structure on my WPMU network. now I have enabled subdomains and installed multisite without a www. For testing purpose, I just create a test site with title as www. (Please see attached shot)

    Now to my surprise, when I was accesing my website with http://www.freewebsitedesigningindia.com with or with out www, it was taking me to my main site. and after creating the test site with www title which makes the website link as http://www.freewebsitedesigningindia.com, it takes me to a entirely different site on my own network.

    Cheers
    PC

  • 3SixtyEvolve
    • New Recruit

    Hi Jack and PC

    As I understand it, when creating sub-domains like sub.mysite.com you can't have www in front of it. When creating a Multisite this message appears:

    We recommend you change your siteurl to mysite.com before enabling the network feature. It will still be possible to visit your site using the www prefix with an address like http://www.mysite.com but any links will not have the www prefix.

    So according to my understanding having www in front of sub-domains is not possible.

    PC, by adding www in front of your sub-domain it is still considered a sub-domain and you would need to use the Domain Mapping plugin to point it to your actual site that has the true www in front of the URL.

    Hope this makes sense?

    Gina

  • intrillion
    • Site Builder, Child of Zeus

    I understand with or without my site is working well.

    I have my domain mapping done, now if i type http://www.mydomainname.com , it will appear as mydomainname.com without the www. The site still work perfectly

    But I prefer the look with http://www.mydomainname.com

    Anyway i can activate it.

    For standalone wordpress, i can just go setting to add www. but for wordpress MU site, the configuration is not possible

  • 3SixtyEvolve
    • New Recruit

    Hi Jack

    I understand from your latest post that you got sorted, albeit not quite as you had hoped, but at least your site is working.

    I once created a site without the www and later wanted to change it to read www. It cost me to uninstall the whole WordPress and reinstall with the www in front of the domain name. So I always make sure in the beginning when setting up a new site whether I want with or without - learned the hard way :slight_smile:

    I will resolve this thread, but please don't hesitate to reopen it if you still require additional feedback from our Support Team. Just select the 'Mark as Not Resolved (re-open)' box below the post area (otherwise we might miss your new post).

    All the best!

    Gina

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.