How To Fix Layout Issues in Portal Theme

Hi,

Just started building a new site. Go to http://dev.collabora365.com/unlimited-windows-web-hosting and click on Buy Now

Notice that the formatting is incorrect in the box where domain names go. Its as if it is a 2-column table with the fields in first column and "www" in second column. The rest of the purchasing seems ok

Any way to straighten this out (literally)?

Also - when I click on Continue Shopping it goes to a whmcs portal page with the group. Can we get this to go back to normal wp site?

Thanks

  • Tyler Postle
    • CGO

    Hey Dean,

    Hope you are doing well today!

    This should straighten it out :slight_smile:

    input#registersld, select#registertld {
    display: inline !important;
    }

    Paste that into a custom CSS field or child theme if you have one - if not, install this plugin here: https://wordpress.org/plugins/simple-custom-css/

    Also - when I click on Continue Shopping it goes to a whmcs portal page with the group. Can we get this to go back to normal wp site?

    The reason it goes to the WHMCS portal page is because the link is generated by the WHMCS shortcode - you would need to find the shortcode in the template files for WHMCS and adjust it there I believe. There could be a setting in your WHMCS setup. Perhaps check there first :slight_smile:

    Hope this helps! Let us know if you have any further questions here.

    All the best,
    Tyler

    • Tyler Postle
      • CGO

      Hey Dean,

      Sorry about that! Worked when I tested it, let's try this one instead :slight_smile:

      Replace the previous code with this:

      .page-id-3271 #top input[type="text"], .page-id-3271 #top select {
      display: inline !important;
      }

      This will only change it on that one page - so if you want it to show on other pages then you may need to take off the two ".page-id-3271".

      Hopefully that one does the trick! Post back if you still need further assistance.

      All the best,
      Tyler

  • Dean
    • Design Lord, Child of Thor

    Well....still no luck. I tried changing whmcs template to classic and default just to see what happens and got same result

    I think when I added the css my cursor ended up on Line 4 creating a blank line. When back-spaced to end of Line 3 I notices that the extension dropdown appears now, but fields are still not lined up

    Both snippets give the same result. I currently have the first one in there now

    Its strange that on the Modern cart, the first Registration option is ok, but not on the other carts

    • Tyler Postle
      • CGO

      Hey Dean,

      Hope your day is going well so far :slight_smile:

      One thing to note is that you need to use the portal template for the integration to work properly. Can you switch to that and let us know if it resolves the issue?

      If not, then can you grant support access? You can do this via WordPress admin - WPMU DEV > Support > Support Access > Grant Access.

      Make sure you have the custom css plugin installed still too, so I can test out a couple CSS styles - this should speed things up a bit so we can get this resolved for you ASAP :slight_smile:

      Look forward to your reply.

      All the best,
      Tyler

    • Tyler Postle
      • CGO

      Hey Dean,

      Hope you're doing well today!

      Thanks for granting access. I went in and took a closer look and found the correct CSS for you. I've already added it to your Custom CSS plugin but you should be able to copy and paste it into your themes css area then delete the custom css plugin if you like :slight_smile:

      Here's the code I added:

      #register input[type="text"], #register select, #transfer input[type="text"], #transfer select, #owndomain input[type="text"] {
        display: inline !important;
      }

      Hope that helps!

      Have a great day Dean.

      Cheers,
      Tyler

  • Dean
    • Design Lord, Child of Thor

    That works. Thanks

    When I use the Quick CSS the CSS doesn't work. I'll just leave the Custom CSS plugin active and let theme developer know?

    We do have a new problem -- checkou know longer works. I get the attached error. Everything seems ok

    • Tyler Postle
      • CGO

      Hey Dean!

      Glad the CSS worked :slight_smile: as for it not working in the theme, perhaps that CSS file is only loaded for theme elements.

      We do have a new problem -- checkou know longer works. I get the attached error. Everything seems ok

      Make sure all the correct URLs are in the right spots according to the installation guide: https://premium.wpmudev.org/project/whmcs-wordpress-integration/#usage

      Especially the URL in your wp backend and the WHMCS System URL in your WHMCS side settings. You will see both illustrated in images via the usage guide :slight_smile:

      Deactivate all other plugins to ensure there is no plugin conflicts occurring here.

      If it's still not working then do you mind send us your login information so we can take a closer look for you? :slight_smile:

      Send in:

      subject: "Attn: Tyler Postle"
      wp admin username
      wp admin password
      login url
      whmcs username
      whmcs password
      whmcs login url
      FTP credentials (host/username/password)

      Select "I have a different question" for your topic - this ensures it gets automatically assigned to me :slight_smile:

      https://premium.wpmudev.org/contact/

      Look forward to hearing back Dean!

      Cheers,
      Tyler

      • Tyler Postle
        • CGO

        Hi Dean,

        Hope you're doing well today, thanks for sending in that information :slight_smile:

        After logged in I noticed that your WHMCS is a dev license. Dev licenses are not meant for live sites and are not allowed to be seen by the public. Ie. only password protected or on localhost.

        This is likely why you're receiving the error, it won't process checkouts because it's communicating with an outside source, your WordPress installation. If you use a production version of WHMCS then all should work as expected :slight_smile:

        Hope this helps! Let me know if you have any further questions on this.

        Look forward to hearing back.

        All the best,
        Tyler

  • Tyler Postle
    • CGO

    Hey Dean,

    Long time no talk! I've just added this CSS to your Appearance > Custom CSS:

    input#registersld, select#registertld {
      display: inline !important;
      width: auto !important;
    }

    It looks to be fixed again for me now :slight_smile:

    Let me know if you still need any further assistance!

    Cheers,
    Tyler

  • Dean
    • Design Lord, Child of Thor

    Making up for lost time haha. ..Still not quite right. It seems the css works only on the top row. See http://dev.collabora365.com/blank/crmportal/cart.php?a=add&pid=35.

    Now check it with 4 rows by adding a domain to cart, continue shopping, then add hosting.
    http://dev.collabora365.com/blank/crmportal/domainchecker.php
    Also, when you go to purchase a domain can we get that page to tighten up. The small text fields are at max width.

    Thanks

  • Tyler Postle
    • CGO

    Hey Dean,

    I've just added the following CSS:

    input#registersld, select#registertld, #domaintransfer input#transfersld, #domaintransfer select#transfertld, input#owndomainsld, input#owndomaintld {
      display: inline !important;
      width: auto !important;
    }
    
    #whmcs_portal .contentbox > input {
      display: inline;
      width: auto;
    }

    Check it out now and let me know what you think :slight_smile:

    Is it the small fields on the domainchecker page you're referring too? I tightened those ones up.

    Hope that helps!

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.