how to get rid of the blogs mu logo in the header for this theme

Hi, I am having trouble trying to remove the Blogs mu logo from the top right in the header for thei theme. I have followed some old threads but to no avail. I have copied the header.php file to blogs-mu-child and replaced line 218 as per the instructions in one of the threads. Then as it had no effect when the folder structure was wp/themes/blogs-mu/themes/blogs-mu-child/ I moved the blogs-mu-child up one to wp/themes/blogs-mu/blogs-mu-child, no effect, then moved it up again to wp/themes/blogs-mu-child. Still no solution to getting rid of the logo. Not sure what to try next? Any ideas please?

Thanks

  • aristath
    • Recruit

    Hello there @rory, I hope you’re well today!

    I’m not sure I completely understand what you’ve done…

    The default folder structure of WordPress is like this:

    <site root>/wp-content/themes/

    In that folder you can have all your other themes.

    That’s where you’ll have to add your child theme…

    I hope that helps!

    If not, could you please elaborate?

    I’ll need some more info…

    Cheers,

    Ari.

  • Mike
    • WPMU DEV Initiate

    Hi @rory

    Your child theme directory should be here:

    <site root>/wp-content/themes/blogs-mu-child/

    Is that where you have it?

    If so have you created the correct stylesheet to set it up as a child theme?

    If not use this code:

    /*
    Theme Name: Blogs MU Child
    Description: Blogs MU Child Theme
    Template: blogs-mu
    */

    @import url("../blogs-mu/style.css");

    Place the above code in a file called ‘style.css’ and place that file in:

    <site root>/wp-content/themes/blogs-mu-child/

    Once that is done activate the theme from the WordPress dashboard and you should be good to go.

    You say you are trying to remove the Blogs MU logo from the top right, do you mean the one on the left above the menu?

    If you want to just replace it with another logo, then upload a logo using the media uploader, then copy the full URL of the uploaded image and paste it in your WordPress dashboard under:

    Appearance -> Theme Options -> Header Settings -> Header Graphics Settings -> Insert your logo full url here

    Then click the save button.

    If you really do want to remove it completely, then copy the header.php to:

    <site root>/wp-content/themes/blogs-mu-child/

    And replace this code from line 216:

    <div class="alignleft">
    <?php if($tn_blogsmu_header_logo != "") { ?>
    <a href="<?php echo home_url(); ?>"><img src="<?php echo stripslashes($tn_blogsmu_header_logo); ?>" alt="logo" /></a>
    <?php } else { ?>
    <a href="<?php echo home_url(); ?>"><img src="<?php echo get_template_directory_uri(); ?>/_inc/images/logo.png" alt="logo" /></a>
    <?php } ?>
    </div>

    With this:

    <!-- div class="alignleft">
    <?php if($tn_blogsmu_header_logo != "") { ?>
    <a href="<?php echo home_url(); ?>"><img src="<?php echo stripslashes($tn_blogsmu_header_logo); ?>" alt="logo" /></a>
    <?php } else { ?>
    <a href="<?php echo home_url(); ?>"><img src="<?php echo get_template_directory_uri(); ?>/_inc/images/logo.png" alt="logo" /></a>
    <?php } ?>
    </div -->

    Then the logo should be gone all together.

    I hope that helps!

  • Rory
    • Flash Drive

    Hi Mike,

    Thanks for your help with this. Sorry I was incorrect about the position of the logo. It is the Blogs Mu on the top left above the menu. The Blogs-mu-child theme is in the correct folder i.e <site root>/wp-content/themes/blogs-mu-child/ and I have copied the style.css file from the Blogs-mu folder into it and modified it as suggested. Also the header.php and replaced the code as suggested. But it has had no effect, the Blogs Mu logo remains. It would seem that the child theme is not being found or activated, but I have no ideas as to why.

    Thanks

    Rory

  • Mike
    • WPMU DEV Initiate

    That’s strange.

    If you want to sent me an email with cpanel and wordpress details I’ll have a quick look or you :slight_smile:

    Send it to mike[at]planet-pcs[dot]com

    That’ll be quicker if you’re ok giving me access for a little while :slight_smile:

  • Mike
    • WPMU DEV Initiate

    @rory In the mean time, here are are some screenshots that might make things a bit clearer:

    Where the styles.css and header.php should be:

    http://awesomescreenshot.com/0a92s9tvb8

    Entire contents of style.css:

    http://awesomescreenshot.com/0612s9u7e1

    Altered section of header.php:

    http://awesomescreenshot.com/0b02s9u9fb

    Ensure that the child theme is active in WordPress:

    http://awesomescreenshot.com/0532s9ug05

    Logo is gone:

    http://awesomescreenshot.com/0242s9ujd1

    Hope that helps a bit more. If not shoot over an email with your cPanel/FTP and WordPress details and I’ll have a look :slight_smile:

  • Mike
    • WPMU DEV Initiate

    Thanks for the email.

    I logged in and the problem was that when copying the code for the stylesheet it was showing encoded quotes(":wink: instead of the actual quotes(“:wink: I fixed this, then activated the theme in WordPress and the result is that the logo is gone.

    Please check it out and let me know :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.