How to get the comment box out of courspresspro pages

Hi,
How can I deactivate the comment box out of coursepress pages started from the one beneath the signup form as shown below;

  • Tyler Postle
    • CGO

    Hey Barni,

    Been seeing you around the forums quite a bit lately :p Keeping busy I assume? Good stuff!

    The comment box shows because you are using real WordPress pages instead of virtual ones and comments are turned on by default on normal WP pages. Fortunately, it is easy to turn them off once you know where to look :slight_smile:

    You need to go to the "edit page" screen for the page you want to turn comments off on, then click the "Screen Options" tab in the top right and check the "discussion" option.

    Now, below your page editor there will be a discussion widget where you can uncheck "allow comments" :slight_smile:

    Hope this helps! Let us know if you need any further assistance here.

    All the best,
    Tyler

  • Barni
    • The Bug Hunter

    @Tyler Postle, thanks, yea, I;ve been around because the project is long over due. Ok, I didn't see any discussion below the pages and I went to the screen option and the comment wasn't activated, yet I see comment box in Coursepress Pro pages. A glitch somehere, seems so. Here is the screenshot inside my wordpress page;

  • Tyler Postle
    • CGO

    Hey Barni,

    You need to check the "discussion" box in the screen options :slight_smile:

    Sorry, I unchecked it after I took the screenshots. I'm too use to testing things then un-doing whatever I change :p

    Once you check that discussion checkbox then you will have the discussion options underneath the page editor.

    Hope this helps!

    All the best,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.