How to insert audio files in Luke+Sara pages?

I have an mp3 file that I've embedded nicely in the theme twentysixteen, but when I try to do the same thing in Luke+Sara, it doesn't show up. Here's the code I'm using:

[embed]http://cpa.ds.npr.org/wvxu/audio/2014/08/CE_061714-23LU.mp3[/embed]

I've tried the text element in Upfront, as well as the code element, both to no avail. Any suggestions?

  • Rupok

    Hi xbladerunner,

    It's working fine in my test site with Luke + Sara theme. I've used the exact code you provided. Please check the attached screenshot for reference.

    But there is a little workaround for making this work. You have to open native WordPress editor for that post/page and paste the embed code there and save. Then you can edit the page with Upfront theme and do the rest of the work. Please check the attached screenshot for reference.

    I've already pinged our Upfront developers regarding this and I believe, they will come up with a solution soon. Either me or them will keep you posted regarding the update.

    Have a nice day. Cheers!
    Rupok

  • xbladerunner

    Thanks Rupork,

    Following your direction I've been able to get it to work, but only on newly created pages... I can't figure out how to get it to show up when editing an existing page. That is, on an existing page with content developed in Upfront, it seems all content entered into the native wordpress text editor is ignored. Can you verify this, or perhaps identify from my description what I am doing wrong?

    The pages I'm editing are pages that where created for the Luke+Sara demo. I renamed them in the native wordpress page editor, then edited their content using Upfront. Presently when I go back to the native wordpress page editor and follow your directions (in this context) the file does not show up in the Upfront editor.

    Is there something else I can do -- other than recreate the page from scratch? Thanks!

  • Kasia Swiderska

    Hello xbladerunner,

    Pre existing pages in Upfront themes does not always have the content element. That is why you are not seeing anything when you edit them in editor.
    You will need to add content element in Upfront. So lets say you already edited page, added shortcode in WordPress editor and saved.
    Edit the same page in Upfront editor and Click "Draggable elements" -> Data. Then move Post Element to place where you need your player.

    Now its matter or choosing right preset that will show only content. Click in the Settings of the element, Presets and choose "content only"

    you will see only player.

    let me know if you need further assistance with this.

    kind regards,
    Kasia