How to install Wordpress on WHMCS with WHMCS WP Integration?

Hi I recently installed WHMCS in my domain folder and it is all set-up. Now what do I do to install wordpress with it? do I move my files into a subfolder? Do I install the wordpress files in the same folder as the WHMCS? if they are in a different folder, won't it be like having 2 sites? I am a bit lost here, thank you

  • Tyler Postle
    • CGO

    Hey Marie,

    Hope you are well today!

    This just brings the WHMCS interface to your WordPress site and domain to make a more seamless experience for your users - they are still separate platforms as far as the backend goes :slight_smile:

    As long as you follow the WHMCS Integration guide: https://premium.wpmudev.org/project/whmcs-wordpress-integration/#usage

    Then it should be all set up.

    If you have a multisite and want to sell your subsites as sites through WHMCS then you can use this plugin as well: https://premium.wpmudev.org/project/whmcs-multisite-provisioning/

    Is there anything else you're wondering here? Just let me know. Happy to help further!

    Cheers,
    Tyler

  • Marie-Neige
    • The Incredible Code Injector

    Hi I read it in full several times before writing to you, I don't know where to send the files and this install already assume wordpress is installed. I have installed many wordpress sites before, that is not the issue, the issue is there is already my WHMCS in the root folder of my domain so do I move it in a folder and send the wordpress files in the root or do I just put the wordpress files in the root too? thank you

  • Tyler Postle
    • CGO

    Hey Marie,

    If your WHMCS is already in your root folder then you can likely put your WordPress in a subdomain if you want. Or you can swap them and have WHMCS as a subdomain or subdirectory(better to be subdomain) or a different domain altogether and just make sure you add it as an add-on domain.

    The important thing is that they both don't reside in the same folder :slight_smile:

    WHMCS integration will function fairly similar to if you had WHMCS in a subdomain and WordPress installed already except that you can use the shortcodes to display your WHMCS content on your actual WordPress site, so your WHMCS users can view everything in one site.

    Hopefully that makes a bit more sense - to be honest it still confuses me sometimes :p

    Let me know if you still have any further questions.

    Cheers,
    Tyler

  • Marie-Neige
    • The Incredible Code Injector

    OK thanks for the info on files upload now it is clear. but if it is only with shortcodes, I see shortcodes about content but the payment gateway, add to cart and show cart will need to be installed as wordpress plugins? so I will need to install also a commerce plugin? and what about WHMCS modules? I have a php module to integrate to WHMCS to my registrar I wish there was a demo I would not be as lost as I am right now! lol anyway right now I will try to move all my files and just work around and see how it goes then

  • Marie-Neige
    • The Incredible Code Injector

    ok so I installed everything, I moved WHMCS to a subfolder, I installed wordpress, installed WHMCS WP Integration, then to enable to single login I enabled the WP network then installed WHMCS Provisioning, both sites are working fine but when I enter the content shortcode I get a blank space under the normal heading.
    I followed the whole instructions here : https://premium.wpmudev.org/project/whmcs-wordpress-integration/#usage
    so my wp install is on nameyour.domains, my WHMCS is at http://nameyour.domains/get/ The template is set to Portal. In WHMCS when The URL to your website homepage is set to http://nameyour.domains/get/ I get the error message above but when I change it to http://nameyour.domains/ then I get just a blank space in the page. At first I had put the ending slug as get but I was afraid of conflicts so I changed it to whmcsportal but still in issue. Regarding the url to encode I am not usre what to put there, I tried both http://nameyour.domains/get/ and http://nameyour.domains/ but it is the same. Also there is no shortcode for the domain name search page, I suppose when we navigate in the portal the links will update and I will be able to add it to my main menu? thank you

  • Tyler Postle
    • CGO

    Hey Marie,

    Hope you're enjoying your weekend so far!

    but when I enter the content shortcode I get a blank space under the normal heading.

    This is likely because the WHMCS content will only show if the user is logged into WHMCS. Login then try the page again :slight_smile:

    Regarding the url to encode I am not usre what to put there

    url encoder isn't a setting, more of a tool. So you don't need to worry about putting anything there really. You can just use it to create your WHMCS specific links to place on your. Here is an excerpt from the usage guide explaining that:

    The WHMCS URL Encoder is not really a setting, but a helper tool to help you get specific WHMCS URLSs that you can use anywhere on your site.

    For example, if you need to link to the shopping cart of your WHMCS install, enter http://your-whmcs-install.com/cart.php and click “Encode URL”. The tool will return the URL you can use for your site, for example: http://your-wp-site.com/whmcs/whmcsportal/cart.php/?

    Note that there are no settings for the selection of a template. Regardless of the template used at your WHMCS install, the plugin will always use the Portal template for seamless integration with your active WordPress theme.

    Also there is no shortcode for the domain name search page, I suppose when we navigate in the portal the links will update and I will be able to add it to my main menu? thank you

    Yes, the client portal will have the links for all that sort of stuff :slight_smile:

    Hope this helps! Let me know if you have any further questions here.

    All the best,
    Tyler

    • Tyler Postle
      • CGO

      Hey Marie,

      Do you mind sending in your WordPress and WHMCS credentials? Then I can take a closer look at exactly what is happening and double check some of the settings for you :slight_smile:

      You can send it in via our private contact form: https://premium.wpmudev.org/contact/

      please include:

      Subject: "Attn: Tyler Postle"
      -WordPress admin username
      -WordPress admin password
      -login url
      -whmcs username
      -whmcs password
      -whmcs login url
      -link back to this thread for reference
      -any other relevant urls

      Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

      That will help speed up the process here.

      Look forward to your reply Marie!

      Cheers,
      Tyler

  • Marie-Neige
    • The Incredible Code Injector

    Hi thanks I got your reply regarding I have to enter the https on every link but this is an issue. before the integration on wordpress, when on the whmcs every time I click on a link that is sensitive as the account or checkout page it would automatically switch to the SSL but with the wordpress integration it won't anymore. I can change my links in the menus but not everywhere (as the portal) and people coming from Google. I am certainly not the first one to have that concern. If it is not possible to control the SSL I will need to remove that plugin. thank you

    • Tyler Postle
      • CGO

      Hey Marie,

      Hope you're doing well today and thanks for getting back to us here :slight_smile: Do you have an SSL certificate for your WordPress installation?

      Have you tried just switching them all to SSL domains, that should give you https secure pages for your WHMCS on the WordPress site :slight_smile:

      Let me know if this helps. If you still have further questions just let me know!

      All the best,
      Tyler

  • Marie-Neige
    • The Incredible Code Injector

    HI Yes fore sure I have a SSL on my domain and for sure it stays in SSL when I manually enter it in the url but my issue now is it won't automatically change to SSL if it is not already (ex coming from a google search result) when going to a sensitive page. It was doing so when I don't integrate worpress with your plugin.

  • Tyler Postle
    • CGO

    Hey Marie,

    Hope you're doing well today and thanks for your patience :slight_smile:

    You should be able to add this to your .htaccess to make it work:

    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteCond %{REQUEST_URI} directory
    RewriteRule ^(.*)$ https://www.example.com/directory/$1 [R,L]

    change the url to yours of course. If your .htaccess already has "rewriteengine on" then you don't need to add it again.

    An alternative here would be to try out this plugin: http://wordpress.org/plugins/wordpress-https/

    It can help force https :slight_smile:

    Note: be sure to make a backup of your .htaccess before making any edits, just in-case.

    Look forward to your reply!

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.